summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2018-02-26 22:44:48 +0800
committerMatt Johnston <matt@ucc.asn.au>2018-02-26 22:44:48 +0800
commit116b062970016395a7e01725f1dccc6564774fc6 (patch)
tree8cafacbf742d8cabd11ff6397d8725f351adcccf /configure.ac
parent84c83f06cd7072e7e61fcf8a046a7670bfe95094 (diff)
parent1e75381de312b1347afcbfc30a20cac6c2ce4738 (diff)
downloaddropbear-116b062970016395a7e01725f1dccc6564774fc6.tar.gz
merge from main
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f8d1b17..6a61d82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,6 +9,12 @@ AC_PREREQ(2.59)
AC_INIT
AC_CONFIG_SRCDIR(buffer.c)
+# Record which revision is being built
+if which -s hg && test -d "$srcdir/.hg"; then
+ hgrev=`hg id -i -R "$srcdir"`
+ echo "Source directory Mercurial base revision $hgrev"
+fi
+
# Checks for programs.
AC_PROG_CC
@@ -315,7 +321,20 @@ AC_ARG_ENABLE(shadow,
AC_MSG_NOTICE(Using shadow passwords if available)
]
)
-
+
+AC_ARG_ENABLE(fuzz,
+ [ --enable-fuzz Build fuzzing],
+ [
+ AC_DEFINE(DROPBEAR_FUZZ, 1, Fuzzing)
+ AC_MSG_NOTICE(Enabling fuzzing)
+ DROPBEAR_FUZZ=1
+ ],
+ [
+ DROPBEAR_FUZZ=0
+ ]
+
+)
+AC_SUBST(DROPBEAR_FUZZ)
# Checks for header files.
AC_HEADER_STDC