summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfabriziobertocci <fabriziobertocci@gmail.com>2019-05-15 09:43:57 -0400
committerfabriziobertocci <fabriziobertocci@gmail.com>2019-05-15 09:43:57 -0400
commit2be32903e09ea1649e59a1202479d32033f282df (patch)
tree6fc4993d64e0a53a2a2b96ec6ed4a5f34177a032 /configure.ac
parent078a5f3821215b668c59b9b8f2abfbeb0c5bbad6 (diff)
downloaddropbear-2be32903e09ea1649e59a1202479d32033f282df.tar.gz
External Public-Key Authentication API (#72)
* Implemented dynamic loading of an external plug-in shared library to delegate public key authentication * Moved conditional compilation of the plugin infrastructure into the configure.ac script to be able to add -ldl to dropbear build only when the flag is enabled * Added tags file to the ignore list * Updated API to have the constructor to return function pointers in the pliugin instance. Added support for passing user name to the checkpubkey function. Added options to the session returned by the plugin and have dropbear to parse and process them * Added -rdynamic to the linker flags when EPKA is enabled * Changed the API to pass a previously created session to the checkPubKey function (created during preauth) * Added documentation to the API * Added parameter addrstring to plugin creation function * Modified the API to retrieve the auth options. Instead of having them as field of the EPKASession struct, they are stored internally (plugin-dependent) in the plugin/session and retrieved through a pointer to a function (in the session) * Changed option string to be a simple char * instead of unsigned char *
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7199d7c..bbbfd02 100644
--- a/configure.ac
+++ b/configure.ac
@@ -323,6 +323,21 @@ AC_ARG_ENABLE(shadow,
]
)
+AC_ARG_ENABLE(epka,
+ [ --enable-epka Enable support for External Public Key Authentication plug-in],
+ [
+ AC_DEFINE(DROPBEAR_EPKA, 1, External Public Key Authentication)
+ AC_MSG_NOTICE(Enabling support for External Public Key Authentication)
+ DROPBEAR_EPKA=1
+ ],
+ [
+ AC_DEFINE(DROPBEAR_EPKA, 0, External Public Key Authentication)
+ DROPBEAR_EPKA=0
+ ]
+
+)
+AC_SUBST(DROPBEAR_EPKA)
+
AC_ARG_ENABLE(fuzz,
[ --enable-fuzz Build fuzzing. Not recommended for deployment.],
[