summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2015-10-21 23:08:22 +0800
committerMatt Johnston <matt@ucc.asn.au>2015-10-21 23:08:22 +0800
commitddc1c3250628cb686d33f2e4fc998f186f31be01 (patch)
tree037acafb312e8529b36d0503bd087f549659462f /configure.ac
parentf1357160d0cea97bed06dbe3804549d91794a04b (diff)
downloaddropbear-ddc1c3250628cb686d33f2e4fc998f186f31be01.tar.gz
Test for crypt() rather than crypt.h
Print a message from configure if getpass() or crypt() were missing
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 15 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e08af5a..ac0528f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -632,7 +632,7 @@ fi
AC_PROG_GCC_TRADITIONAL
AC_FUNC_MEMCMP
AC_FUNC_SELECT_ARGTYPES
-AC_CHECK_FUNCS([dup2 getpass getspnam getusershell memset putenv select socket strdup clearenv strlcpy strlcat daemon basename _getpty getaddrinfo freeaddrinfo getnameinfo fork writev])
+AC_CHECK_FUNCS([dup2 getpass getspnam getusershell memset putenv select socket strdup clearenv strlcpy strlcat daemon basename _getpty getaddrinfo freeaddrinfo getnameinfo fork writev crypt])
AC_SEARCH_LIBS(basename, gen, AC_DEFINE(HAVE_BASENAME))
@@ -719,10 +719,21 @@ AC_OUTPUT
AC_MSG_NOTICE()
if test $BUNDLED_LIBTOM = 1 ; then
-AC_MSG_NOTICE(Using bundled libtomcrypt and libtommath)
+AC_MSG_NOTICE([Using bundled libtomcrypt and libtommath])
else
-AC_MSG_NOTICE(Using system libtomcrypt and libtommath)
+AC_MSG_NOTICE([Using system libtomcrypt and libtommath])
+fi
+
+
+if test "x$ac_cv_func_getpass" != xyes; then
+AC_MSG_NOTICE()
+AC_MSG_NOTICE([getpass() not available, dbclient will only have public-key authentication])
+fi
+
+if test "x$ac_cv_func_crypt" != xyes; then
+AC_MSG_NOTICE()
+AC_MSG_NOTICE([crypt() not available, dropbear server will not have password authentication])
fi
AC_MSG_NOTICE()
-AC_MSG_NOTICE(Now edit options.h to choose features.)
+AC_MSG_NOTICE([Now edit options.h to choose features.])