summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5d792df..958e1a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -287,7 +287,20 @@ AC_ARG_ENABLE(shadow,
AC_MSG_NOTICE(Using shadow passwords if available)
]
)
-
+
+AC_ARG_ENABLE(fuzz,
+ [ --enable-fuzz Build fuzzing],
+ [
+ AC_DEFINE(DROPBEAR_FUZZ, 1, Fuzzing)
+ AC_MSG_NOTICE(Enabling fuzzing)
+ DROPBEAR_FUZZ=1
+ ],
+ [
+ DROPBEAR_FUZZ=0
+ ]
+
+)
+AC_SUBST(DROPBEAR_FUZZ)
# Checks for header files.
AC_HEADER_STDC