summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorVincent Torri <vincent.torri@gmail.com>2008-10-26 07:05:11 +0000
committerVincent Torri <vincent.torri@gmail.com>2008-10-26 07:05:11 +0000
commit6071006636c894d15cce28bc59b20ccc8fabf54e (patch)
treee49c65d52010c8f409b0320aa9e34122bf8bc84b /doc/Makefile.am
parent601705696fd51494c12b8ac1515c0185d8b94824 (diff)
downloadeet-6071006636c894d15cce28bc59b20ccc8fabf54e.tar.gz
autotools cleanups:
* reorganize configure.ac * select default opptions in configure.ac (disable openssl for windows ce) * fix Libs.private field and add Requires field in eep.pc * rename eet.c.in to eet.dox.in * use css file from other packages. Now the doc is correctly displayd (need a rename of eet.css to e.css, though. will be next commit) SVN revision: 37114
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am25
1 files changed, 13 insertions, 12 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 8d3bf95..bbf1c9e 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,23 +1,25 @@
-MAINTAINERCLEANFILES = Makefile.in eet.c
+MAINTAINERCLEANFILES = Makefile.in eet.dox
.PHONY: doc
+PACKAGE_DOCNAME = $(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc
+
if EFL_BUILD_DOC
doc-clean:
- rm -rf html/ latex/ man/ xml/ $(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar*
+ rm -rf html/ latex/ man/ xml/ $(PACKAGE_DOCNAME).tar*
doc: all doc-clean
$(DOXYGEN)
- cp img/*.png html/
- rm -rf $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION).tar*
- mkdir -p $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION)/doc
- cp -R html/ latex/ man/ $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION)/doc
- tar cf $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION).tar $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION)
- bzip2 -9 $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION).tar
- rm -rf $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION)
- mv $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION).tar.bz2 $(top_srcdir)
+ cp img/* html/
+ rm -rf $(PACKAGE_DOCNAME).tar*
+ mkdir -p $(PACKAGE_DOCNAME)/doc
+ cp -R html/ latex/ man/ $(PACKAGE_DOCNAME)/doc
+ tar cf $(PACKAGE_DOCNAME).tar $(PACKAGE_DOCNAME)/
+ bzip2 -9 $(PACKAGE_DOCNAME).tar
+ rm -rf $(PACKAGE_DOCNAME)/
+ mv $(PACKAGE_DOCNAME).tar.bz2 $(top_srcdir)
clean-local: doc-clean
@@ -28,5 +30,4 @@ doc:
endif
-EXTRA_DIST = Doxyfile eet.css foot.html head.html img/ eet.c.in
-
+EXTRA_DIST = Doxyfile eet.css foot.html head.html img/ eet.dox.in