summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorVincent Torri <vincent.torri@gmail.com>2008-10-16 08:41:40 +0000
committerVincent Torri <vincent.torri@gmail.com>2008-10-16 08:41:40 +0000
commit995b30b244ae5e8f1d08726a5140eee5cf4b11d2 (patch)
tree971032a7ed13a5049c82902bf8252ba50122c4e7 /doc/Makefile.am
parenta2069d86802ec40bfc87b8e990392634f1b3b3a3 (diff)
downloadeet-995b30b244ae5e8f1d08726a5140eee5cf4b11d2.tar.gz
* add m4 macro for documentation, unit tests and coverage
* put documentation related files in doc, remove gendoc and add a doc rule to create the documentation and a doc tarball named eet-doc-$(version).tar.bz2 * minor cleanup in the autotools SVN revision: 36706
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am56
1 files changed, 21 insertions, 35 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 5744849..346819a 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,46 +1,32 @@
-if BUILD_DOCS
-
-# install documentation
-docdir = $(datadir)/$(PACKAGE)/doc
-
-all-local: doc-build.stamp
-
-# rule to remove all old created files
-doc-prepare.stamp:
- @if test -d html ; then \
- rm -rf html/ latex/ man/ xml/; \
- fi
-
-# rule to build documentation and copy necessary files
-doc-build.stamp: doc-prepare.stamp
- @doxygen
- @cp img/*.png html/
+MAINTAINERCLEANFILES = Makefile.in eet.c
-# rules to clean
-clean-local:
- @rm -rf html/ latex/ man/ xml/
+.PHONY: doc
-# rule to install the documentation in $(docdir)
-install-data-local:
- @if ! test -d "$(DESTDIR)$(datadir)/$(PACKAGE)"; then \
- $(mkinstalldirs) "$(DESTDIR)$(datadir)/$(PACKAGE)"; \
- fi
- @if ! test -d "$(DESTDIR)$(docdir)"; then \
- $(mkinstalldirs) "$(DESTDIR)$(docdir)"; \
- fi
- @cp -pr html/ man/ latex/ xml/ "$(DESTDIR)$(docdir)"
+if EFL_BUILD_DOC
-# rule to uninstall the documentation
-uninstall-local:
- rm -rf $(DESTDIR)$(docdir)
+doc-clean:
+ rm -rf html/ latex/ man/ xml/ $(PACKAGE_TARNAME)-$(PACKAGE_VERSION).tar*
+doc: all doc-clean
+ $(DOXYGEN)
+ cp img/*.png html/
+ rm -rf $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION).tar*
+ mkdir -p $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION)/doc
+ cp -R html/ latex/ man/ $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION)/doc
+ tar cf $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION).tar $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION)
+ bzip2 -9 $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION).tar
+ rm -rf $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION)
+ mv $(PACKAGE_TARNAME)-doc-$(PACKAGE_VERSION).tar.bz2 $(top_srcdir)
-MAINTAINERCLEANFILES = Makefile.in eet.c
+else
-DISTCLEANFILES = Makefile.in eet.c
+doc:
+ @echo "Documentation not built. Run ./configure --help"
endif
-EXTRA_DIST = Doxyfile eet.css foot.html head.html img/
+clean-local: doc-clean
+
+EXTRA_DIST = Doxyfile eet.css foot.html head.html img/ eet.c.in