summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authordoursse <doursse>2005-09-27 22:10:09 +0000
committerdoursse <doursse@7cbeb6ba-43b4-40fd-8cce-4c39aea84d33>2005-09-27 22:10:09 +0000
commitaa957571d948244b873c252cbd2cce1a05cda872 (patch)
tree7beb64c1201edc3ad29a4a8383deffbc84bddb97 /doc/Makefile.am
parentfb7c5bcce63073bd0d3e983e7559fc5345cb2bba (diff)
downloadeet-aa957571d948244b873c252cbd2cce1a05cda872.tar.gz
installation of the doc with the autofoo. gendoc is not used anymore. The documentation is built and installed only if doxygen exists. If it's good, I'll commit the same stuff for the other packages
SVN revision: 17001
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..db14644
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,34 @@
+
+if BUILD_DOCS
+
+# install documentation
+docdir = $(datadir)/$(PACKAGE)/doc
+
+all-local: doc-build.stamp
+
+# rule to remove all old created files
+doc-prepare.stamp:
+ @if test x"html" != x ; then \
+ rm -rf html/ latex/ man/ xml/; \
+ fi
+
+# rule to build documentation and copy necessary files
+doc-build.stamp: doc-prepare.stamp
+ @doxygen
+ @cp img/*.png html/
+
+# rule to install the documentation in $(docdir)
+install-data-local:
+ @if ! test -d $(datadir)/$(PACKAGE); then \
+ mkdir $(datadir)/$(PACKAGE); \
+ fi
+ @if ! test -d $(docdir); then \
+ mkdir $(docdir); \
+ fi
+ @cp -pr html/ man/ latex/ xml/ $(docdir)
+
+# rule to uninstall the documentation
+uninstall-local:
+ rm -rf $(docdir)
+
+endif