summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-29 07:56:42 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-29 07:56:42 +0000
commiteefcf05d0a889c5d99f373e678a3a5417e24644a (patch)
tree079dd9a934a97750774123adae59e77c371333ac /doc/Makefile.am
parentdd71ca444a91308be86695832e4fca2738790625 (diff)
downloadeet-eefcf05d0a889c5d99f373e678a3a5417e24644a.tar.gz
respect $(DESTDIR) as reported by Mike Russo via e-mail
SVN revision: 17060
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index db14644..844a02f 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -19,13 +19,13 @@ doc-build.stamp: doc-prepare.stamp
# rule to install the documentation in $(docdir)
install-data-local:
- @if ! test -d $(datadir)/$(PACKAGE); then \
- mkdir $(datadir)/$(PACKAGE); \
+ @if ! test -d "$(DESTDIR)$(datadir)/$(PACKAGE)"; then \
+ mkdir "$(DESTDIR)$(datadir)/$(PACKAGE)"; \
fi
- @if ! test -d $(docdir); then \
- mkdir $(docdir); \
+ @if ! test -d "$(DESTDIR)$(docdir)"; then \
+ mkdir "$(DESTDIR)$(docdir)"; \
fi
- @cp -pr html/ man/ latex/ xml/ $(docdir)
+ @cp -pr html/ man/ latex/ xml/ "$(DESTDIR)$(docdir)"
# rule to uninstall the documentation
uninstall-local: