summaryrefslogtreecommitdiff
path: root/libc/configure.in
diff options
context:
space:
mode:
authorjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2008-08-19 17:24:09 +0000
committerjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2008-08-19 17:24:09 +0000
commit447fd9179ef3effda7c99168c310c5e0d0e8e770 (patch)
treef90fa016ce2e15d5b509f124107ea12273ee605e /libc/configure.in
parent46a638ad529cc323bb7fbd02968b0770ab6626e8 (diff)
downloadeglibc2-447fd9179ef3effda7c99168c310c5e0d0e8e770.tar.gz
Merge changes between r6509 and r6780 from /fsf/trunk.
git-svn-id: svn://svn.eglibc.org/trunk@6785 7b3dc134-2b1b-0410-93df-9e9f96275f8d
Diffstat (limited to 'libc/configure.in')
-rw-r--r--libc/configure.in17
1 files changed, 16 insertions, 1 deletions
diff --git a/libc/configure.in b/libc/configure.in
index 4af921126..4225dcef0 100644
--- a/libc/configure.in
+++ b/libc/configure.in
@@ -326,7 +326,6 @@ AC_ARG_WITH([cpu],
esac
])
-
# An add-on can set this when it wants to disable the sanity check below.
libc_config_ok=no
@@ -1967,6 +1966,22 @@ EOF
fi
fi
+if test -n "$submachine"; then
+ AC_CACHE_CHECK([for compiler option for CPU variant],
+ libc_cv_cc_submachine, [dnl
+ libc_cv_cc_submachine=no
+ for opt in "-march=$submachine" "-mcpu=$submachine"; do
+ if AC_TRY_COMMAND([${CC-cc} $opt -xc /dev/null -S -o /dev/null]); then
+ libc_cv_cc_submachine="$opt"
+ break
+ fi
+ done])
+ if test "x$libc_cv_cc_submachine" = xno; then
+ AC_MSG_ERROR([${CC-cc} does not support $submachine])
+ fi
+fi
+AC_SUBST(libc_cv_cc_submachine)
+
dnl Check whether we have the gd library available.
AC_MSG_CHECKING(for libgd)
if test "$with_gd" != "no"; then