summaryrefslogtreecommitdiff
path: root/ports/sysdeps/arm/eabi/Makefile
diff options
context:
space:
mode:
authorjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2012-04-21 17:19:39 +0000
committerjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2012-04-21 17:19:39 +0000
commitded28410835671021876e845572816d3083efe34 (patch)
treed1f9b748d0c562708657f80cd2830c7582d455f6 /ports/sysdeps/arm/eabi/Makefile
parent854e95fe80cf2750477daaa1fcce14b8ef43418c (diff)
downloadeglibc2-ded28410835671021876e845572816d3083efe34.tar.gz
Merge changes between r17813 and r18165 from /fsf/trunk.
git-svn-id: svn://svn.eglibc.org/trunk@18166 7b3dc134-2b1b-0410-93df-9e9f96275f8d
Diffstat (limited to 'ports/sysdeps/arm/eabi/Makefile')
-rw-r--r--ports/sysdeps/arm/eabi/Makefile38
1 files changed, 0 insertions, 38 deletions
diff --git a/ports/sysdeps/arm/eabi/Makefile b/ports/sysdeps/arm/eabi/Makefile
deleted file mode 100644
index 97bb49552..000000000
--- a/ports/sysdeps/arm/eabi/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-ifeq ($(subdir),csu)
-aeabi_constants = aeabi_lcsts aeabi_sighandlers aeabi_math
-aeabi_routines = aeabi_assert aeabi_errno_addr \
- aeabi_mb_cur_max aeabi_atexit aeabi_memclr aeabi_memcpy \
- aeabi_memmove aeabi_memset
-ifeq (y,$(OPTION_EGLIBC_LOCALE_CODE))
-aeabi_routines += aeabi_localeconv
-endif
-
-sysdep_routines += $(aeabi_constants) $(aeabi_routines)
-static-only-routines += $(aeabi_constants)
-
-# get offset to rtld_global._dl_hwcap
-gen-as-const-headers += rtld-global-offsets.sym
-endif
-
-ifeq ($(subdir),gmon)
-sysdep_routines += arm-mcount
-endif
-
-ifeq ($(subdir),debug)
-CFLAGS-backtrace.c += -funwind-tables
-CFLAGS-tst-backtrace2.c += -funwind-tables
-CFLAGS-tst-backtrace3.c += -funwind-tables
-CFLAGS-tst-backtrace4.c += -funwind-tables
-CFLAGS-tst-backtrace5.c += -funwind-tables
-CFLAGS-tst-backtrace6.c += -funwind-tables
-endif
-
-ifeq ($(subdir),elf)
-sysdep_routines += aeabi_unwind_cpp_pr1 find_exidx
-shared-only-routines += aeabi_unwind_cpp_pr1
-sysdep-rtld-routines += aeabi_unwind_cpp_pr1
-endif
-
-ifeq ($(subdir),math)
-$(objpfx)libm.so: $(elfobjdir)/ld.so
-endif