summaryrefslogtreecommitdiff
path: root/libc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'libc/configure.in')
-rw-r--r--libc/configure.in26
1 files changed, 20 insertions, 6 deletions
diff --git a/libc/configure.in b/libc/configure.in
index 05cbad50e..03e5a8faa 100644
--- a/libc/configure.in
+++ b/libc/configure.in
@@ -146,6 +146,13 @@ else
fi
AC_SUBST(oldest_abi)
+AC_ARG_ENABLE([hardcoded-path-in-tests],
+ AC_HELP_STRING([--enable-hardcoded-path-in-tests],
+ [hardcode newly built glibc path in tests @<:@default=no@:>@]),
+ [hardcoded_path_in_tests=$enableval],
+ [hardcoded_path_in_tests=no])
+AC_SUBST(hardcoded_path_in_tests)
+
AC_ARG_ENABLE([stackguard-randomization],
AC_HELP_STRING([--enable-stackguard-randomization],
[initialize __stack_chk_guard canary with a random number at program start]),
@@ -626,6 +633,7 @@ if test x"$libc_cv_ld_gnu_indirect_function" != xyes; then
multi_arch=no
fi
fi
+multi_arch_d=
if test x"$multi_arch" != xno; then
multi_arch_d=/multiarch
fi
@@ -679,11 +687,16 @@ while m=`echo $tail | sed 's@^\(.*\)/\([^/]*\)$@& \1@'`; test -n "$m"; do
set $m
# Prepend the machine's FPU directory unless --without-fp.
if test "$with_fp" = yes; then
- mach="$mach /$1/fpu"
+ maybe_fpu=/fpu
else
- mach="$mach /$1/nofpu"
+ maybe_fpu=/nofpu
fi
- mach="$mach /$1"
+ # For each machine term, try it with and then without /multiarch.
+ for try_fpu in $maybe_fpu ''; do
+ for try_multi in $multi_arch_d ''; do
+ mach="$mach /$1$try_fpu$try_multi"
+ done
+ done
tail="$2"
done
@@ -699,15 +712,16 @@ for b in $base ''; do
test "$v" = / && continue
for o in /$ostry ''; do
test "$o" = / && continue
- for m in $multi_arch_d $mach ''; do
+ for m in $mach ''; do
for d in $add_ons_pfx ''; do
for a in $add_ons_sfx ''; do
- if test -n "$m0$m0sub$b$v$o$m$msub"; then
+ try_suffix="$m0$b$v$o$m"
+ if test -n "$try_suffix"; then
try_srcdir="${srcdir}/"
case "$d" in
/*) try_srcdir= ;;
esac
- try="${d}sysdeps$m0$m0sub$b$v$o$m$msub$a"
+ try="${d}sysdeps$try_suffix$a"
test -n "$enable_debug_configure" &&
echo "$0 [DEBUG]: try $try" >&2
if test -d "$try_srcdir$try"; then