summaryrefslogtreecommitdiff
path: root/libc/ports/sysdeps/hppa/nptl
diff options
context:
space:
mode:
Diffstat (limited to 'libc/ports/sysdeps/hppa/nptl')
-rw-r--r--libc/ports/sysdeps/hppa/nptl/Makefile8
-rw-r--r--libc/ports/sysdeps/hppa/nptl/shlib-versions1
-rw-r--r--libc/ports/sysdeps/hppa/nptl/tst-oddstacklimit.c26
3 files changed, 28 insertions, 7 deletions
diff --git a/libc/ports/sysdeps/hppa/nptl/Makefile b/libc/ports/sysdeps/hppa/nptl/Makefile
index 86be06ade..bc09dd1e7 100644
--- a/libc/ports/sysdeps/hppa/nptl/Makefile
+++ b/libc/ports/sysdeps/hppa/nptl/Makefile
@@ -1,4 +1,4 @@
-# Copyright (C) 2005 Free Software Foundation, Inc.
+# Copyright (C) 2005-2012 Free Software Foundation, Inc.
# This file is part of the GNU C Library.
#
# The GNU C Library is free software; you can redistribute it and/or
@@ -18,9 +18,3 @@
ifeq ($(subdir),csu)
gen-as-const-headers += tcb-offsets.sym
endif
-
-# This sets the stack resource limit to 8193kb, which is not a multiple
-# of the page size, and therefore an odd sized stack limit. We override
-# this because the default is too small to run with.
-tst-oddstacklimit-ENV = ; ulimit -s 8193;
-
diff --git a/libc/ports/sysdeps/hppa/nptl/shlib-versions b/libc/ports/sysdeps/hppa/nptl/shlib-versions
new file mode 100644
index 000000000..adc26364b
--- /dev/null
+++ b/libc/ports/sysdeps/hppa/nptl/shlib-versions
@@ -0,0 +1 @@
+hppa.*-.*-linux.* libpthread=0 GLIBC_2.2
diff --git a/libc/ports/sysdeps/hppa/nptl/tst-oddstacklimit.c b/libc/ports/sysdeps/hppa/nptl/tst-oddstacklimit.c
new file mode 100644
index 000000000..6fcc9e312
--- /dev/null
+++ b/libc/ports/sysdeps/hppa/nptl/tst-oddstacklimit.c
@@ -0,0 +1,26 @@
+/* Test NPTL with stack limit that is not a multiple of the page size.
+ HPPA version.
+ Copyright (C) 2012 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+
+ The GNU C Library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License, or (at your option) any later version.
+
+ The GNU C Library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with the GNU C Library; if not, see
+ <http://www.gnu.org/licenses/>. */
+
+/* This sets the stack resource limit to 8193kb, which is not a multiple
+ of the page size, and therefore an odd sized stack limit. We override
+ this because the default is too small to run with. */
+
+#define ODD_STACK_LIMIT (8193 * 1024)
+
+#include <sysdeps/../nptl/tst-oddstacklimit.c>