summaryrefslogtreecommitdiff
path: root/libc/ports/sysdeps/unix/sysv/linux
diff options
context:
space:
mode:
Diffstat (limited to 'libc/ports/sysdeps/unix/sysv/linux')
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/aarch64/Makefile6
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/aarch64/Versions6
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/aarch64/dl-static.c84
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/aarch64/ldsodefs.h32
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/aarch64/sys/ptrace.h21
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/ia64/sys/ptrace.h21
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/tile/Makefile6
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/tile/Versions6
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/tile/dl-static.c84
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/tile/ldsodefs.h32
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/tile/sys/ptrace.h37
11 files changed, 332 insertions, 3 deletions
diff --git a/libc/ports/sysdeps/unix/sysv/linux/aarch64/Makefile b/libc/ports/sysdeps/unix/sysv/linux/aarch64/Makefile
index 97c179add..8a3d76be6 100644
--- a/libc/ports/sysdeps/unix/sysv/linux/aarch64/Makefile
+++ b/libc/ports/sysdeps/unix/sysv/linux/aarch64/Makefile
@@ -7,6 +7,12 @@ endif
ifeq ($(subdir),elf)
sysdep_routines += dl-vdso
sysdep-rtld-routines += __read_tp
+ifeq ($(build-shared),yes)
+# This is needed for DSO loading from static binaries.
+sysdep-dl-routines += dl-static
+sysdep_routines += dl-static
+sysdep-rtld-routines += dl-static
+endif
endif
ifeq ($(subdir),misc)
diff --git a/libc/ports/sysdeps/unix/sysv/linux/aarch64/Versions b/libc/ports/sysdeps/unix/sysv/linux/aarch64/Versions
index 627ff5352..9bd87fe2d 100644
--- a/libc/ports/sysdeps/unix/sysv/linux/aarch64/Versions
+++ b/libc/ports/sysdeps/unix/sysv/linux/aarch64/Versions
@@ -1,3 +1,9 @@
+ld {
+ GLIBC_PRIVATE {
+ # used for loading by static libraries
+ _dl_var_init;
+ }
+}
libc {
GLIBC_PRIVATE {
__vdso_clock_gettime;
diff --git a/libc/ports/sysdeps/unix/sysv/linux/aarch64/dl-static.c b/libc/ports/sysdeps/unix/sysv/linux/aarch64/dl-static.c
new file mode 100644
index 000000000..13b48e933
--- /dev/null
+++ b/libc/ports/sysdeps/unix/sysv/linux/aarch64/dl-static.c
@@ -0,0 +1,84 @@
+/* Variable initialization. AArch64 version.
+ Copyright (C) 2001-2013 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+
+ The GNU C Library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License, or (at your option) any later version.
+
+ The GNU C Library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with the GNU C Library. If not, see
+ <http://www.gnu.org/licenses/>. */
+
+#include <ldsodefs.h>
+
+#ifdef SHARED
+
+void
+_dl_var_init (void *array[])
+{
+ /* It has to match "variables" below. */
+ enum
+ {
+ DL_PAGESIZE = 0
+ };
+
+ GLRO(dl_pagesize) = *((size_t *) array[DL_PAGESIZE]);
+}
+
+#else
+
+static void *variables[] =
+{
+ &GLRO(dl_pagesize)
+};
+
+static void
+_dl_unprotect_relro (struct link_map *l)
+{
+ ElfW(Addr) start = ((l->l_addr + l->l_relro_addr)
+ & ~(GLRO(dl_pagesize) - 1));
+ ElfW(Addr) end = ((l->l_addr + l->l_relro_addr + l->l_relro_size)
+ & ~(GLRO(dl_pagesize) - 1));
+
+ if (start != end)
+ __mprotect ((void *) start, end - start, PROT_READ | PROT_WRITE);
+}
+
+void
+_dl_static_init (struct link_map *l)
+{
+ struct link_map *rtld_map = l;
+ struct r_scope_elem **scope;
+ const ElfW(Sym) *ref = NULL;
+ lookup_t loadbase;
+ void (*f) (void *[]);
+ size_t i;
+
+ loadbase = _dl_lookup_symbol_x ("_dl_var_init", l, &ref, l->l_local_scope,
+ NULL, 0, 1, NULL);
+
+ for (scope = l->l_local_scope; *scope != NULL; scope++)
+ for (i = 0; i < (*scope)->r_nlist; i++)
+ if ((*scope)->r_list[i] == loadbase)
+ {
+ rtld_map = (*scope)->r_list[i];
+ break;
+ }
+
+ if (ref != NULL)
+ {
+ f = (void (*) (void *[])) DL_SYMBOL_ADDRESS (loadbase, ref);
+ _dl_unprotect_relro (rtld_map);
+ f (variables);
+ _dl_protect_relro (rtld_map);
+ }
+}
+
+#endif
diff --git a/libc/ports/sysdeps/unix/sysv/linux/aarch64/ldsodefs.h b/libc/ports/sysdeps/unix/sysv/linux/aarch64/ldsodefs.h
new file mode 100644
index 000000000..92877e53d
--- /dev/null
+++ b/libc/ports/sysdeps/unix/sysv/linux/aarch64/ldsodefs.h
@@ -0,0 +1,32 @@
+/* Run-time dynamic linker data structures for loaded ELF shared objects. Tile.
+ Copyright (C) 2001-2013 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+
+ The GNU C Library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License, or (at your option) any later version.
+
+ The GNU C Library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with the GNU C Library; if not, see
+ <http://www.gnu.org/licenses/>. */
+
+#ifndef _LDSODEFS_H
+
+/* Get the real definitions. */
+#include_next <ldsodefs.h>
+
+/* Now define our stuff. */
+
+/* We need special support to initialize DSO loaded for statically linked
+ binaries. */
+extern void _dl_static_init (struct link_map *map);
+#undef DL_STATIC_INIT
+#define DL_STATIC_INIT(map) _dl_static_init (map)
+
+#endif /* ldsodefs.h */
diff --git a/libc/ports/sysdeps/unix/sysv/linux/aarch64/sys/ptrace.h b/libc/ports/sysdeps/unix/sysv/linux/aarch64/sys/ptrace.h
index 7c1e68365..71e1dec11 100644
--- a/libc/ports/sysdeps/unix/sysv/linux/aarch64/sys/ptrace.h
+++ b/libc/ports/sysdeps/unix/sysv/linux/aarch64/sys/ptrace.h
@@ -21,6 +21,7 @@
#define _SYS_PTRACE_H 1
#include <features.h>
+#include <bits/types.h>
__BEGIN_DECLS
@@ -123,7 +124,11 @@ enum __ptrace_request
#define PTRACE_INTERRUPT PTRACE_INTERRUPT
/* Wait for next group event. */
- PTRACE_LISTEN = 0x4208
+ PTRACE_LISTEN = 0x4208,
+#define PTRACE_LISTEN PTRACE_LISTEN
+
+ PTRACE_PEEKSIGINFO = 0x4209
+#define PTRACE_PEEKSIGINFO PTRACE_PEEKSIGINFO
};
@@ -159,6 +164,20 @@ enum __ptrace_eventcodes
PTRACE_EVENT_SECCOMP = 7
};
+/* Arguments for PTRACE_PEEKSIGINFO. */
+struct ptrace_peeksiginfo_args
+{
+ __uint64_t off; /* From which siginfo to start. */
+ __uint32_t flags; /* Flags for peeksiginfo. */
+ __int32_t nr; /* How many siginfos to take. */
+};
+
+enum __ptrace_peeksiginfo_flags
+{
+ /* Read signals from a shared (process wide) queue. */
+ PTRACE_PEEKSIGINFO_SHARED = (1 << 0)
+};
+
/* Perform process tracing functions. REQUEST is one of the values
above, and determines the action to be taken.
For all requests except PTRACE_TRACEME, PID specifies the process to be
diff --git a/libc/ports/sysdeps/unix/sysv/linux/ia64/sys/ptrace.h b/libc/ports/sysdeps/unix/sysv/linux/ia64/sys/ptrace.h
index c18d31424..d6f390841 100644
--- a/libc/ports/sysdeps/unix/sysv/linux/ia64/sys/ptrace.h
+++ b/libc/ports/sysdeps/unix/sysv/linux/ia64/sys/ptrace.h
@@ -21,6 +21,7 @@
#include <features.h>
#include <sys/ucontext.h>
+#include <bits/types.h>
__BEGIN_DECLS
@@ -128,7 +129,11 @@ enum __ptrace_request
#define PTRACE_INTERRUPT PTRACE_INTERRUPT
/* Wait for next group event. */
- PTRACE_LISTEN = 0x4208
+ PTRACE_LISTEN = 0x4208,
+#define PTRACE_LISTEN PTRACE_LISTEN
+
+ PTRACE_PEEKSIGINFO = 0x4209
+#define PTRACE_PEEKSIGINFO PTRACE_PEEKSIGINFO
};
@@ -179,6 +184,20 @@ enum __ptrace_eventcodes
PTRACE_EVENT_SECCOMP = 7
};
+/* Arguments for PTRACE_PEEKSIGINFO. */
+struct ptrace_peeksiginfo_args
+{
+ __uint64_t off; /* From which siginfo to start. */
+ __uint32_t flags; /* Flags for peeksiginfo. */
+ __int32_t nr; /* How many siginfos to take. */
+};
+
+enum __ptrace_peeksiginfo_flags
+{
+ /* Read signals from a shared (process wide) queue. */
+ PTRACE_PEEKSIGINFO_SHARED = (1 << 0)
+};
+
/* Perform process tracing functions. REQUEST is one of the values
above, and determines the action to be taken.
For all requests except PTRACE_TRACEME, PID specifies the process to be
diff --git a/libc/ports/sysdeps/unix/sysv/linux/tile/Makefile b/libc/ports/sysdeps/unix/sysv/linux/tile/Makefile
index 1c0c968dc..0bcb95f63 100644
--- a/libc/ports/sysdeps/unix/sysv/linux/tile/Makefile
+++ b/libc/ports/sysdeps/unix/sysv/linux/tile/Makefile
@@ -16,4 +16,10 @@ endif
ifeq ($(subdir),elf)
sysdep_routines += dl-vdso
+ifeq ($(build-shared),yes)
+# This is needed for DSO loading from static binaries.
+sysdep-dl-routines += dl-static
+sysdep_routines += dl-static
+sysdep-rtld-routines += dl-static
+endif
endif
diff --git a/libc/ports/sysdeps/unix/sysv/linux/tile/Versions b/libc/ports/sysdeps/unix/sysv/linux/tile/Versions
index 1df7518c7..9b40d2839 100644
--- a/libc/ports/sysdeps/unix/sysv/linux/tile/Versions
+++ b/libc/ports/sysdeps/unix/sysv/linux/tile/Versions
@@ -1,3 +1,9 @@
+ld {
+ GLIBC_PRIVATE {
+ # used for loading by static libraries
+ _dl_var_init;
+ }
+}
libc {
GLIBC_2.12 {
_flush_cache;
diff --git a/libc/ports/sysdeps/unix/sysv/linux/tile/dl-static.c b/libc/ports/sysdeps/unix/sysv/linux/tile/dl-static.c
new file mode 100644
index 000000000..5b59a04dc
--- /dev/null
+++ b/libc/ports/sysdeps/unix/sysv/linux/tile/dl-static.c
@@ -0,0 +1,84 @@
+/* Variable initialization. Tile version.
+ Copyright (C) 2001-2013 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+
+ The GNU C Library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License, or (at your option) any later version.
+
+ The GNU C Library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with the GNU C Library. If not, see
+ <http://www.gnu.org/licenses/>. */
+
+#include <ldsodefs.h>
+
+#ifdef SHARED
+
+void
+_dl_var_init (void *array[])
+{
+ /* It has to match "variables" below. */
+ enum
+ {
+ DL_PAGESIZE = 0
+ };
+
+ GLRO(dl_pagesize) = *((size_t *) array[DL_PAGESIZE]);
+}
+
+#else
+
+static void *variables[] =
+{
+ &GLRO(dl_pagesize)
+};
+
+static void
+_dl_unprotect_relro (struct link_map *l)
+{
+ ElfW(Addr) start = ((l->l_addr + l->l_relro_addr)
+ & ~(GLRO(dl_pagesize) - 1));
+ ElfW(Addr) end = ((l->l_addr + l->l_relro_addr + l->l_relro_size)
+ & ~(GLRO(dl_pagesize) - 1));
+
+ if (start != end)
+ __mprotect ((void *) start, end - start, PROT_READ | PROT_WRITE);
+}
+
+void
+_dl_static_init (struct link_map *l)
+{
+ struct link_map *rtld_map = l;
+ struct r_scope_elem **scope;
+ const ElfW(Sym) *ref = NULL;
+ lookup_t loadbase;
+ void (*f) (void *[]);
+ size_t i;
+
+ loadbase = _dl_lookup_symbol_x ("_dl_var_init", l, &ref, l->l_local_scope,
+ NULL, 0, 1, NULL);
+
+ for (scope = l->l_local_scope; *scope != NULL; scope++)
+ for (i = 0; i < (*scope)->r_nlist; i++)
+ if ((*scope)->r_list[i] == loadbase)
+ {
+ rtld_map = (*scope)->r_list[i];
+ break;
+ }
+
+ if (ref != NULL)
+ {
+ f = (void (*) (void *[])) DL_SYMBOL_ADDRESS (loadbase, ref);
+ _dl_unprotect_relro (rtld_map);
+ f (variables);
+ _dl_protect_relro (rtld_map);
+ }
+}
+
+#endif
diff --git a/libc/ports/sysdeps/unix/sysv/linux/tile/ldsodefs.h b/libc/ports/sysdeps/unix/sysv/linux/tile/ldsodefs.h
new file mode 100644
index 000000000..92877e53d
--- /dev/null
+++ b/libc/ports/sysdeps/unix/sysv/linux/tile/ldsodefs.h
@@ -0,0 +1,32 @@
+/* Run-time dynamic linker data structures for loaded ELF shared objects. Tile.
+ Copyright (C) 2001-2013 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+
+ The GNU C Library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License, or (at your option) any later version.
+
+ The GNU C Library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with the GNU C Library; if not, see
+ <http://www.gnu.org/licenses/>. */
+
+#ifndef _LDSODEFS_H
+
+/* Get the real definitions. */
+#include_next <ldsodefs.h>
+
+/* Now define our stuff. */
+
+/* We need special support to initialize DSO loaded for statically linked
+ binaries. */
+extern void _dl_static_init (struct link_map *map);
+#undef DL_STATIC_INIT
+#define DL_STATIC_INIT(map) _dl_static_init (map)
+
+#endif /* ldsodefs.h */
diff --git a/libc/ports/sysdeps/unix/sysv/linux/tile/sys/ptrace.h b/libc/ports/sysdeps/unix/sysv/linux/tile/sys/ptrace.h
index 55d541dd7..5740dacfe 100644
--- a/libc/ports/sysdeps/unix/sysv/linux/tile/sys/ptrace.h
+++ b/libc/ports/sysdeps/unix/sysv/linux/tile/sys/ptrace.h
@@ -20,6 +20,7 @@
#define _SYS_PTRACE_H 1
#include <features.h>
+#include <bits/types.h>
__BEGIN_DECLS
@@ -101,8 +102,28 @@ enum __ptrace_request
#define PT_GETSIGINFO PTRACE_GETSIGINFO
/* Set new siginfo for process. */
- PTRACE_SETSIGINFO = 0x4203
+ PTRACE_SETSIGINFO = 0x4203,
#define PT_SETSIGINFO PTRACE_SETSIGINFO
+
+ /* Set register content. */
+ PTRACE_SETREGSET = 0x4205,
+#define PTRACE_SETREGSET PTRACE_SETREGSET
+
+ /* Like PTRACE_ATTACH, but do not force tracee to trap and do not affect
+ signal or group stop state. */
+ PTRACE_SEIZE = 0x4206,
+#define PTRACE_SEIZE PTRACE_SEIZE
+
+ /* Trap seized tracee. */
+ PTRACE_INTERRUPT = 0x4207,
+#define PTRACE_INTERRUPT PTRACE_INTERRUPT
+
+ /* Wait for next group event. */
+ PTRACE_LISTEN = 0x4208,
+#define PTRACE_LISTEN PTRACE_LISTEN
+
+ PTRACE_PEEKSIGINFO = 0x4209
+#define PTRACE_PEEKSIGINFO PTRACE_PEEKSIGINFO
};
@@ -132,6 +153,20 @@ enum __ptrace_eventcodes
PTRACE_EVENT_SECCOMP = 7
};
+/* Arguments for PTRACE_PEEKSIGINFO. */
+struct ptrace_peeksiginfo_args
+{
+ __uint64_t off; /* From which siginfo to start. */
+ __uint32_t flags; /* Flags for peeksiginfo. */
+ __int32_t nr; /* How many siginfos to take. */
+};
+
+enum __ptrace_peeksiginfo_flags
+{
+ /* Read signals from a shared (process wide) queue. */
+ PTRACE_PEEKSIGINFO_SHARED = (1 << 0)
+}
+
/* Perform process tracing functions. REQUEST is one of the values
above, and determines the action to be taken.
For all requests except PTRACE_TRACEME, PID specifies the process to be