summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorVincent Torri <vincent.torri@gmail.com>2008-09-28 12:43:21 +0000
committerVincent Torri <vincent.torri@gmail.com>2008-09-28 12:43:21 +0000
commitc8e9f31e94c678e96c710d840bd4055327fdadfa (patch)
tree33dd8cea3cf396b5e4aebc4a9c07c34a2b90a9ff /Makefile.am
parentee68dd4b327986c544d8d3b95d182e825d96b2d2 (diff)
downloadeina-c8e9f31e94c678e96c710d840bd4055327fdadfa.tar.gz
* fix clean and dist rules
* create eina-$(maj_version).pc.in file automatically SVN revision: 36292
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 12 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 1a9109e..dc9596c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,34 +4,32 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = src doc
+DISTCLEANFILES = \
+eina-@VMAJ@.pc.in
+
MAINTAINERCLEANFILES = \
Makefile.in \
aclocal.m4 \
config.guess \
config.h.in \
+config.h.in~ \
config.sub \
configure \
+depcomp \
install-sh \
ltconfig \
ltmain.sh \
-missing mkinstalldirs \
-stamp-h.in \
-build-stamp \
-configure-stamp \
-depcomp \
-eina.pc \
-eina_docs.tar.gz
+missing
EXTRA_DIST = \
AUTHORS \
COPYING \
-gendoc \
-Doxyfile \
+OLD-COPYING.PLAIN \
README \
-eina.pc
+eina-@VMAJ@.pc.in
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = eina.pc
+pkgconfig_DATA = eina-@VMAJ@.pc
.PHONY: doc coverage benchmark
@@ -76,9 +74,6 @@ coverage:
@make lcov-reset
@make check
@make lcov-report
-
-clean-local:
- @rm -rf coverage benchmark
else
lcov-reset:
@echo "reconfigure with --enable-coverage"
@@ -102,3 +97,6 @@ else
benchmark:
@echo "reconfigure with --enable-bench"
endif
+
+clean-local:
+ @rm -rf coverage benchmark