summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorVincent Torri <vincent.torri@gmail.com>2008-08-27 13:34:04 +0000
committerVincent Torri <vincent.torri@gmail.com>2008-08-27 13:34:04 +0000
commitf6c8712e40732996c62f1a2d892b28c0d9fdd839 (patch)
treed2966a9ef9dc5d779838ac23c44ff3aef44cd069 /Makefile.am
parentda1a4c21e962223aaf3c97488633bea6c1f61f9c (diff)
downloadeina-f6c8712e40732996c62f1a2d892b28c0d9fdd839.tar.gz
Update documentation:
* run 'make doc' to generate the documentation. Hence gendoc disappear. Doxyfile is moved to doc/ * update main page and doc of hash table, but it has to be filled. SVN revision: 35692
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e362699..9f640b9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = src
+SUBDIRS = src doc
MAINTAINERCLEANFILES = \
Makefile.in \
@@ -33,6 +33,14 @@ eina.pc
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = eina.pc
+.PHONY: doc coverage benchmark
+
+# Documentation
+
+doc:
+ @echo "entering doc/"
+ make -C doc doc
+
# Unit tests
if EINA_ENABLE_TESTS
@@ -85,12 +93,12 @@ endif
if EINA_ENABLE_BENCH
benchmark:
- @make -C src bench
+ @make -C src benchmark
@mkdir result || true
@cd result && ../src/tests/eina_bench `date +%F_%T`
else
-bench:
+benchmark:
@echo "reconfigure with --enable-bench"
endif