summaryrefslogtreecommitdiff
path: root/backends/Makefile.am
diff options
context:
space:
mode:
authorYouling Tang <tangyouling@loongson.cn>2023-04-07 10:59:27 +0800
committerMark Wielaard <mark@klomp.org>2023-05-09 11:53:01 +0200
commit686ae59f620893d84ddea3702b116fd20e043114 (patch)
tree1f22bfe675dc01738fdad744e96ad109a829a7d0 /backends/Makefile.am
parentfd16a21a1ac7c999194cb75f473c4fcab76dabe8 (diff)
downloadelfutils-686ae59f620893d84ddea3702b116fd20e043114.tar.gz
backends: Add frame pointer unwinding for LoongArch
If we don't find any debug information for a given frame, we usually cannot unwind any further. However, the binary in question might have been compiled with frame pointers, in which case we can look up the well known frame pointer locations in the stack snapshot and use them to bridge the frames without debug information. Signed-off-by: Liwei Ge <geliwei@openanolis.org> Signed-off-by: Youling Tang <tangyouling@loongson.cn>
Diffstat (limited to 'backends/Makefile.am')
-rw-r--r--backends/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/backends/Makefile.am b/backends/Makefile.am
index 50e78ea5..1261f5c6 100644
--- a/backends/Makefile.am
+++ b/backends/Makefile.am
@@ -97,7 +97,8 @@ csky_SRCS = csky_attrs.c csky_init.c csky_symbol.c csky_cfi.c \
csky_regs.c csky_initreg.c csky_corenote.c
loongarch_SRCS = loongarch_init.c loongarch_symbol.c loongarch_cfi.c \
- loongarch_regs.c loongarch_retval.c
+ loongarch_regs.c loongarch_retval.c \
+ loongarch_unwind.c
arc_SRCS = arc_init.c arc_symbol.c