summaryrefslogtreecommitdiff
path: root/libdw/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2014-10-06 22:00:16 +0200
committerMark Wielaard <mjw@redhat.com>2014-11-05 14:31:33 +0100
commit3a36e8a26c32103ec2f8edda8bf212d6883970a2 (patch)
tree0b76055b98d20af626f04022d4987a4de8b812a3 /libdw/Makefile.am
parent564cfbe20beb077c3441400c4b0c406478043d76 (diff)
downloadelfutils-3a36e8a26c32103ec2f8edda8bf212d6883970a2.tar.gz
libdw: Add dwarf_peel_type. Use it in dwarf_aggregate_size.
Add new function dwarf_peel_type. Some type annotations in DWARF are specified by modifier tag type wrappers instead of attributes. For type aliases (typedef) and qualifiers (const, volatile, restrict) tags dwarf_peel_type follows the DW_AT_type attributes till it finds a base, user-defined, reference or pointer type DIE. Use this new function in the backends for return type DIEs (replacing the existing dwarf_peel_type there) and in dwarf_aggregate_size so it can provide the sizes for qualified types too. Add a new version and testcase for the new dwarf_aggregate_size functionality. Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'libdw/Makefile.am')
-rw-r--r--libdw/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libdw/Makefile.am b/libdw/Makefile.am
index 2e42a376..859af4d4 100644
--- a/libdw/Makefile.am
+++ b/libdw/Makefile.am
@@ -87,7 +87,7 @@ libdw_a_SOURCES = dwarf_begin.c dwarf_begin_elf.c dwarf_end.c dwarf_getelf.c \
dwarf_aggregate_size.c dwarf_getlocation_implicit_pointer.c \
dwarf_getlocation_die.c dwarf_getlocation_attr.c \
dwarf_getalt.c dwarf_setalt.c dwarf_cu_getdwarf.c \
- dwarf_cu_die.c
+ dwarf_cu_die.c dwarf_peel_type.c
if MAINTAINER_MODE
BUILT_SOURCES = $(srcdir)/known-dwarf.h