summaryrefslogtreecommitdiff
path: root/libdw/Makefile.am
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@gmail.com>2014-12-18 12:32:39 -0500
committerMark Wielaard <mjw@redhat.com>2014-12-18 23:47:22 +0100
commit898ed261444cdd817c2d9b3656209a291eb5e807 (patch)
tree32764f1005d8f80ed45c394c02c7867b8caed1fb /libdw/Makefile.am
parent09dc83d67f16f378cd3f9901ab39fcd87aa08aeb (diff)
downloadelfutils-898ed261444cdd817c2d9b3656209a291eb5e807.tar.gz
avoid scary command output
The commands to check for invalid text relocations in the generated DSOs shouldn't be displayed. They contain an echo which prints the text. This patch suppresses the commands from being printed.
Diffstat (limited to 'libdw/Makefile.am')
-rw-r--r--libdw/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libdw/Makefile.am b/libdw/Makefile.am
index 7a2a25d3..887da6b0 100644
--- a/libdw/Makefile.am
+++ b/libdw/Makefile.am
@@ -113,7 +113,7 @@ libdw.so$(EXEEXT): $(srcdir)/libdw.map libdw_pic.a ../libdwelf/libdwelf_pic.a \
-Wl,--version-script,$<,--no-undefined \
-Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
-ldl $(zip_LIBS)
- $(textrel_check)
+ @$(textrel_check)
ln -fs $@ $@.$(VERSION)
install: install-am libdw.so