summaryrefslogtreecommitdiff
path: root/libebl/Makefile.am
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2005-08-13 01:59:10 +0000
committerRoland McGrath <roland@redhat.com>2005-08-13 01:59:10 +0000
commit653d3763e986da9f1c8a92ff9103d85c534754cd (patch)
tree66c2402ec55cf778e36e98c52e5c5d5c4e9aae25 /libebl/Makefile.am
parent1c83bf1fd46b74492297694b642df36d18c6e7b5 (diff)
downloadelfutils-653d3763e986da9f1c8a92ff9103d85c534754cd.tar.gz
libebl/
2005-08-12 Roland McGrath <roland@redhat.com> * libeblP.h (struct ebl): Add bss_plt_p hook. * eblopenbackend.c (default_bss_plt_p): New function. (fill_defaults): Use it. * eblbsspltp.c: New file. * Makefile.am (gen_SOURCES): Add it. * libebl.h: Declare ebl_bss_plt_p. * ppc_symbol.c (ppc_bss_plt_p): New function. * libebl_ppc.h: Declare it. * ppc_init.c (ppc_init): Use it. * ppc64_symbol.c (ppc64_bss_plt_p): New function. * libebl_ppc64.h: Declare it. * ppc64_init.c (ppc64_init): Use it. * ebl_check_special_symbol.c: New file. * Makefile.am (gen_SOURCES): Add it. * libebl.h: Declare ebl_check_special_symbol. * libeblP.h (struct ebl): Add check_special_symbol hook. * eblopenbackend.c (default_check_special_symbol): New function. (fill_defaults): Use it. * ppc_symbol.c (ppc_check_special_symbol): New function. * libebl_ppc.h: Add prototype. * ppc_init.c (ppc_init): Use it. * ppc64_symbol.c (ppc64_check_special_symbol): New function. * libebl_ppc64.h: Add prototype. * ppc64_init.c (ppc64_init): Use it. src/ 2005-08-12 Roland McGrath <roland@redhat.com> * elflint.c (check_symtab): Check that _GLOBAL_OFFSET_TABLE_ st_shndx refers to the right section if it's not SHN_ABS. Let ebl_check_special_symbol override _G_O_T_ value and size checks. * elflint.c (check_sections): Don't complain about a non-NOBITS section taking no segment space, if it's sh_size is 0. * elflint.c (check_sections): Use ebl_bss_plt_p to see if .plt should be PROGBITS or NOBITS. * elflint.c (check_symtab): Use ebl_check_special_symbol to override standard st_value and st_size checks.
Diffstat (limited to 'libebl/Makefile.am')
-rw-r--r--libebl/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/libebl/Makefile.am b/libebl/Makefile.am
index eeac7e54..ead129bd 100644
--- a/libebl/Makefile.am
+++ b/libebl/Makefile.am
@@ -48,7 +48,8 @@ gen_SOURCES = eblopenbackend.c eblclosebackend.c eblstrtab.c \
ebldynamictagcheck.c eblcorenotetypename.c eblobjnotetypename.c \
eblcorenote.c eblobjnote.c ebldebugscnp.c \
eblgotpcreloccheck.c eblcopyrelocp.c eblsectionstripp.c \
- eblelfclass.c eblelfdata.c eblelfmachine.c
+ eblelfclass.c eblelfdata.c eblelfmachine.c \
+ ebl_check_special_symbol.c eblbsspltp.c
libebl_a_SOURCES = $(gen_SOURCES)