summaryrefslogtreecommitdiff
path: root/libelf/Makefile.am
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2005-08-28 16:18:57 +0000
committerUlrich Drepper <drepper@redhat.com>2005-08-28 16:18:57 +0000
commit3d413d4b05005bbd4c384b60e3797caf57f120d5 (patch)
treeae6da630ac134df6f899ad827fb62d1ac46f4c2f /libelf/Makefile.am
parent28f5be122f9fc70056082b63db119b256bc029c4 (diff)
downloadelfutils-3d413d4b05005bbd4c384b60e3797caf57f120d5.tar.gz
Implement --enable-gconv option for configure.
Diffstat (limited to 'libelf/Makefile.am')
-rw-r--r--libelf/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/libelf/Makefile.am b/libelf/Makefile.am
index 28d0d6ed..17851fc5 100644
--- a/libelf/Makefile.am
+++ b/libelf/Makefile.am
@@ -92,9 +92,9 @@ am_libelf_pic_a_OBJECTS = $(libelf_a_SOURCES:.c=.os)
libelf_so_SOURCES =
libelf.so: libelf_pic.a libelf.map
- $(CC) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
- -Wl,--version-script,$(srcdir)/libelf.map,--no-undefined \
- -Wl,--soname,$@.$(VERSION),-z,-defs
+ $(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
+ -Wl,--version-script,$(srcdir)/libelf.map,--no-undefined \
+ -Wl,--soname,$@.$(VERSION),-z,-defs
if readelf -d $@ | fgrep -q TEXTREL; then exit 1; fi
ln -fs $@ $@.$(VERSION)
@@ -122,4 +122,4 @@ noinst_HEADERS = elf.h abstract.h common.h exttypes.h gelf_xlate.h libelfP.h \
version_xlate.h dl-hash.h
EXTRA_DIST = libelf.map
-CLEANFILES = $(am_libelf_pic_a_OBJECTS)
+CLEANFILES = $(am_libelf_pic_a_OBJECTS) *.gcno *.gcda