summaryrefslogtreecommitdiff
path: root/libelf/Makefile.am
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2009-01-10 18:02:05 -0800
committerUlrich Drepper <drepper@redhat.com>2009-01-10 18:02:05 -0800
commit7e678fa3f6051f7ef24b4610c9a66cab858b6b6e (patch)
treefed33d7f4b2d3fe6651bf016e8cabcf26bbb1e42 /libelf/Makefile.am
parenta4b1a95434b90ed147e33363d92e24a035b6b775 (diff)
downloadelfutils-7e678fa3f6051f7ef24b4610c9a66cab858b6b6e.tar.gz
Require __thread support in compiler.
Rename --enable-tls to more appropriate --enable-thread-safety.
Diffstat (limited to 'libelf/Makefile.am')
-rw-r--r--libelf/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libelf/Makefile.am b/libelf/Makefile.am
index 2458ecbd..84b01a86 100644
--- a/libelf/Makefile.am
+++ b/libelf/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to create Makefile.in
##
-## Copyright (C) 1996-2006, 2007, 2008 Red Hat, Inc.
+## Copyright (C) 1996-2006, 2007, 2008, 2009 Red Hat, Inc.
## This file is part of Red Hat elfutils.
##
## Red Hat elfutils is free software; you can redistribute it and/or modify
@@ -106,7 +106,7 @@ libelf_pic_a_SOURCES =
am_libelf_pic_a_OBJECTS = $(libelf_a_SOURCES:.c=.os)
libelf_so_LDLIBS =
-if USE_TLS
+if USE_LOCKS
libelf_so_LDLIBS += -lpthread
endif