summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Schwab <schwab@suse.de>2007-09-01 23:26:52 +0000
committerAndreas Schwab <schwab@suse.de>2007-09-01 23:26:52 +0000
commit28aa2c3e65bfbbd8a1db965b41e5a2632d53f147 (patch)
treec66d273ad8f95f6b79c6b230859c57d0f47e576f /configure.in
parent7a5e3e973f65c392ef86be21272fda2f4a0d1c67 (diff)
downloademacs-28aa2c3e65bfbbd8a1db965b41e5a2632d53f147.tar.gz
Put quotes around nested macro calls.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 16 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index fc49170bf94..4db05455ba8 100644
--- a/configure.in
+++ b/configure.in
@@ -2281,7 +2281,7 @@ if test "${HAVE_GTK}" = "yes"; then
CFLAGS="$CFLAGS $XFT_CFLAGS"
LIBS="$XFT_LIBS $LIBS"
AC_CHECK_HEADER(X11/Xft/Xft.h,
- AC_CHECK_LIB(Xft, XftFontOpen, HAVE_XFT=yes, , $XFT_LIBS))
+ [AC_CHECK_LIB(Xft, XftFontOpen, HAVE_XFT=yes, , $XFT_LIBS)])
if test "${HAVE_XFT}" = "yes"; then
AC_DEFINE(HAVE_XFT, 1, [Define to 1 if you have the Xft library.])
@@ -2458,8 +2458,8 @@ AC_TRY_COMPILE([
#include <X11/Xlib.h>
#include <X11/Xresource.h>],
[XIMProc callback;],
- HAVE_XIM=yes
- AC_DEFINE(HAVE_XIM, 1, [Define to 1 if XIM is available]),
+ [HAVE_XIM=yes
+ AC_DEFINE(HAVE_XIM, 1, [Define to 1 if XIM is available])],
HAVE_XIM=no)
dnl `--with-xim' now controls only the initial value of use_xim at run time.
@@ -2509,7 +2509,7 @@ HAVE_XPM=no
if test "${HAVE_X11}" = "yes"; then
if test "${with_xpm}" != "no"; then
AC_CHECK_HEADER(X11/xpm.h,
- AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, HAVE_XPM=yes, , -lX11))
+ [AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, HAVE_XPM=yes, , -lX11)])
if test "${HAVE_XPM}" = "yes"; then
AC_MSG_CHECKING(for XpmReturnAllocPixels preprocessor define)
AC_EGREP_CPP(no_return_alloc_pixels,
@@ -2539,7 +2539,7 @@ if test "${HAVE_X11}" = "yes"; then
dnl Checking for jpeglib.h can lose because of a redefinition of
dnl HAVE_STDLIB_H.
AC_CHECK_HEADER(jerror.h,
- AC_CHECK_LIB(jpeg, jpeg_destroy_compress, HAVE_JPEG=yes))
+ [AC_CHECK_LIB(jpeg, jpeg_destroy_compress, HAVE_JPEG=yes)])
fi
AH_TEMPLATE(HAVE_JPEG, [Define to 1 if you have the jpeg library (-ljpeg).])dnl
@@ -2549,7 +2549,7 @@ if test "${HAVE_X11}" = "yes"; then
[#include <jpeglib.h>
version=JPEG_LIB_VERSION
],
- AC_DEFINE(HAVE_JPEG),
+ [AC_DEFINE(HAVE_JPEG)],
[AC_MSG_WARN([libjpeg found, but not version 6b or later])
HAVE_JPEG=no])
fi
@@ -2577,10 +2577,10 @@ HAVE_TIFF=no
if test "${HAVE_X11}" = "yes"; then
if test "${with_tiff}" != "no"; then
AC_CHECK_HEADER(tiffio.h,
- tifflibs="-lz -lm"
+ [tifflibs="-lz -lm"
# At least one tiff package requires the jpeg library.
if test "${HAVE_JPEG}" = yes; then tifflibs="-ljpeg $tifflibs"; fi
- AC_CHECK_LIB(tiff, TIFFGetVersion, HAVE_TIFF=yes, , $tifflibs))
+ AC_CHECK_LIB(tiff, TIFFGetVersion, HAVE_TIFF=yes, , $tifflibs)])
fi
if test "${HAVE_TIFF}" = "yes"; then
@@ -2594,7 +2594,7 @@ if test "${HAVE_X11}" = "yes" && test "${with_gif}" != "no"; then
AC_CHECK_HEADER(gif_lib.h,
# EGifPutExtensionLast only exists from version libungif-4.1.0b1.
# Earlier versions can crash Emacs.
- AC_CHECK_LIB(gif, EGifPutExtensionLast, HAVE_GIF=yes, try_libungif=yes))
+ [AC_CHECK_LIB(gif, EGifPutExtensionLast, HAVE_GIF=yes, try_libungif=yes)])
if test "$HAVE_GIF" = yes; then
ac_gif_lib_name="-lgif"
@@ -2644,7 +2644,7 @@ fi
HAVE_GPM=no
if test "${with_gpm}" != "no"; then
AC_CHECK_HEADER(gpm.h,
- AC_CHECK_LIB(gpm, Gpm_Open, HAVE_GPM=yes))
+ [AC_CHECK_LIB(gpm, Gpm_Open, HAVE_GPM=yes)])
fi
if test "${HAVE_GPM}" = "yes"; then
@@ -2652,7 +2652,7 @@ if test "${HAVE_GPM}" = "yes"; then
fi
dnl Check for malloc/malloc.h on darwin
-AC_CHECK_HEADER(malloc/malloc.h, AC_DEFINE(HAVE_MALLOC_MALLOC_H, 1, [Define to 1 if you have the <malloc/malloc.h> header file.]))
+AC_CHECK_HEADER(malloc/malloc.h, [AC_DEFINE(HAVE_MALLOC_MALLOC_H, 1, [Define to 1 if you have the <malloc/malloc.h> header file.])])
### Use Mac OS X Carbon API to implement GUI.
if test "${HAVE_CARBON}" = "yes"; then
@@ -2673,7 +2673,7 @@ fi
HAVE_X_SM=no
if test "${HAVE_X11}" = "yes"; then
AC_CHECK_HEADER(X11/SM/SMlib.h,
- AC_CHECK_LIB(SM, SmcOpenConnection, HAVE_X_SM=yes, , -lICE))
+ [AC_CHECK_LIB(SM, SmcOpenConnection, HAVE_X_SM=yes, , -lICE)])
if test "${HAVE_X_SM}" = "yes"; then
AC_DEFINE(HAVE_X_SM, 1, [Define to 1 if you have the SM library (-lSM).])
@@ -2784,8 +2784,8 @@ if test "$with_hesiod" = yes ; then
RESOLVLIB=
fi
AC_CHECK_FUNC(hes_getmailhost, , [AC_CHECK_LIB(hesiod, hes_getmailhost,
- AC_DEFINE(HAVE_LIBHESIOD, 1,
- [Define to 1 if you have the hesiod library (-lhesiod).]),
+ [AC_DEFINE(HAVE_LIBHESIOD, 1,
+ [Define to 1 if you have the hesiod library (-lhesiod).])],
:, $RESOLVLIB)])
fi
@@ -2797,9 +2797,9 @@ if test "${with_kerberos+set}" = set; then
AC_CHECK_LIB(krb5, krb5_init_context)
if test "${with_kerberos5+set}" != set; then
AC_CHECK_LIB(des425, des_cbc_encrypt,,
- AC_CHECK_LIB(des, des_cbc_encrypt))
+ [AC_CHECK_LIB(des, des_cbc_encrypt)])
AC_CHECK_LIB(krb4, krb_get_cred,,
- AC_CHECK_LIB(krb, krb_get_cred))
+ [AC_CHECK_LIB(krb, krb_get_cred)])
fi
if test "${with_kerberos5+set}" = set; then