summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard M. Stallman <rms@gnu.org>2002-03-01 16:24:37 +0000
committerRichard M. Stallman <rms@gnu.org>2002-03-01 16:24:37 +0000
commit4d766b593cc0cfa0e214d747e8172ec0adcce6dd (patch)
tree51c1e4d7825fc94d64f23ae3270884bab043c7f1 /configure.in
parent857b864af1baa11116ee722a5acb5d102b39d696 (diff)
downloademacs-4d766b593cc0cfa0e214d747e8172ec0adcce6dd.tar.gz
(HAVE_JPEG): Turn it off if libjpeg version < 6b.
(HAVE_GIF): Don't use old libungif versions that crash.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 74b953c9e37..c59caae1e5d 100644
--- a/configure.in
+++ b/configure.in
@@ -1878,6 +1878,16 @@ if test "${HAVE_X11}" = "yes"; then
if test "${HAVE_JPEG}" = "yes"; then
AC_DEFINE(HAVE_JPEG)
+ AC_EGREP_CPP(
+changequote({, })dnl avoid leadingspace on the next line
+{version= *(6[2-9]|[7-9][0-9])},
+changequote([, ])dnl
+ [#include <jpeglib.h>
+ version=JPEG_LIB_VERSION
+],
+ AC_DEFINE(HAVE_JPEG),
+ [AC_MSG_WARN([libjpeg found, but not version 6b or later])
+ HAVE_JPEG=no])
fi
fi
@@ -1915,7 +1925,9 @@ HAVE_GIF=no
if test "${HAVE_X11}" = "yes"; then
if test "${with_gif}" != "no"; then
AC_CHECK_HEADER(gif_lib.h,
- AC_CHECK_LIB(ungif, DGifOpen, HAVE_GIF=yes))
+# EGifPutExtensionLast only exists from version libungif-4.1.0b1.
+# Earlier versions can crash Emacs.
+ AC_CHECK_LIB(ungif, EGifPutExtensionLast, HAVE_GIF=yes))
fi
if test "${HAVE_GIF}" = "yes"; then