summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKen Raeburn <raeburn@raeburn.org>2000-06-30 22:02:25 +0000
committerKen Raeburn <raeburn@raeburn.org>2000-06-30 22:02:25 +0000
commit5a9bf171d00b1f74e66803d57e45cff779bc0752 (patch)
treee4dc9e377b8ed7ff4ad518c604e121fee954124b /configure.in
parent97d176db6bf737df6490822aff18423d9df9879b (diff)
downloademacs-5a9bf171d00b1f74e66803d57e45cff779bc0752.tar.gz
* configure.in: Add ${C_SWITCH_X_SITE} temporarily to CPPFLAGS, while
searching for image-handling libraries.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1152b795d8d..b4e63069a3c 100644
--- a/configure.in
+++ b/configure.in
@@ -1549,11 +1549,14 @@ AC_MSG_RESULT($HAVE_XFREE386)
# Change CFLAGS temporarily so that C_SWITCH_X_SITE gets used
# for the tests that follow. We set it back to REAL_CFLAGS later on.
+REAL_CPPFLAGS="$CPPFLAGS"
+
if test "${HAVE_X11}" = "yes"; then
DEFS="$C_SWITCH_X_SITE $DEFS"
LDFLAGS="$LDFLAGS $LD_SWITCH_X_SITE"
LIBS="$LIBX $LIBS"
CFLAGS="$C_SWITCH_X_SITE $CFLAGS"
+ CPPFLAGS="$C_SWITCH_X_SITE $CPPFLAGS"
# On Solaris, arrange for LD_RUN_PATH to point to the X libraries for tests.
# This is handled by LD_SWITCH_X_SITE_AUX during the real build,
@@ -2061,6 +2064,7 @@ AC_FUNC_VFORK
# Set up the CFLAGS for real compilation, so we can substitute it.
CFLAGS="$REAL_CFLAGS"
+CPPFLAGS="$REAL_CPPFLAGS"
changequote(, )dnl
#### Find out which version of Emacs this is.