summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorReuben Thomas <rrt@sc3d.org>2021-11-09 13:03:08 +0000
committerGitHub <noreply@github.com>2021-11-09 13:03:08 +0000
commite0d44f3d0e2ec9b40c7662fda7a6e10465028e4f (patch)
tree7236a0654ad13c95f756ec8db5a7fb9072b99062 /src/Makefile.am
parent9bd442f2e48cd4e605bbdf2f8a2e8c3ec02418ac (diff)
parent34eed0fbd502cc3980e7931dbdb4e9379b34252d (diff)
downloadenchant-e0d44f3d0e2ec9b40c7662fda7a6e10465028e4f.tar.gz
Merge pull request #291 from rrthomas/master
Minor fixes and cleanup
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 912c1a6..35ff7ea 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -25,7 +25,7 @@ pkgdata_DATA = enchant.ordering
dist_man_MANS = enchant-@ENCHANT_MAJOR_VERSION@.1 enchant-lsmod-@ENCHANT_MAJOR_VERSION@.1
edit = sed \
- -e 's|@datadir[@]|$(datadir)|g'
+ -e 's|DATADIR|$(datadir)|g'
DISTCLEANFILES = $(dist_man_MANS)
@@ -35,9 +35,7 @@ enchant-@ENCHANT_MAJOR_VERSION@.1: $(builddir)/enchant.1 Makefile.am $(top_build
mv $@.tmp $@
enchant-lsmod-@ENCHANT_MAJOR_VERSION@.1: $(builddir)/enchant-lsmod.1 Makefile.am $(top_builddir)/config.status
- rm -f $@ $@.tmp
- $(edit) $(abs_builddir)/enchant-lsmod.1 >$@.tmp
- mv $@.tmp $@
+ cp $(abs_builddir)/enchant-lsmod.1 $@
LDADD = libenchant-@ENCHANT_MAJOR_VERSION@.la $(ENCHANT_LIBS) $(top_builddir)/lib/libgnu.la
bin_PROGRAMS = enchant-@ENCHANT_MAJOR_VERSION@ enchant-lsmod-@ENCHANT_MAJOR_VERSION@