summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorReuben Thomas <rrt@sc3d.org>2017-03-03 20:09:18 +0000
committerReuben Thomas <rrt@sc3d.org>2017-03-03 20:11:43 +0000
commitd5aafe00da470b88f41f5f0ecc296ccbf1d2f0ba (patch)
tree3f036ecd11a61d8b3047715864913c817595c869 /tests/Makefile.am
parent73ce4ceee2d6c87b1110fca39bee95b079b95054 (diff)
downloadenchant-d5aafe00da470b88f41f5f0ecc296ccbf1d2f0ba.tar.gz
Remove ENCHANT_MODULE_PATH environment variable
Not needed any longer for testing (use ENCHANT_PREFIX_DIR); for other purposes it’s mostly useful for chaos (e.g. code injection into applications using Enchant).
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index aa44c03..56cd12b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,13 +1,15 @@
AM_CPPFLAGS = -I$(top_srcdir)/src $(ENCHANT_CFLAGS)
AM_TESTS_ENVIRONMENT = \
- ENCHANT_MODULE_PATH=$(top_builddir)/providers/@objdir@; \
- export ENCHANT_MODULE_PATH; \
- rm -f test.pwl; \
+ ENCHANT_PREFIX_DIR=""; \
+ export ENCHANT_PREFIX_DIR; \
+ rm -f test.pwl enchant; \
+ mkdir -p lib/enchant; \
+ cp $(top_builddir)/providers/@objdir@/*@shlibext@ lib/enchant || :;
cp $(srcdir)/test.pwl.orig $(builddir)/test.pwl; \
chmod +w $(builddir)/test.pwl;
-DISTCLEANFILES = test.pwl
+DISTCLEANFILES = test.pwl lib/enchant/*@shlibext@
EXTRA_DIST = test.pwl.orig