summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 78df0ce..60abf42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,6 +78,8 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wconversion" # These warnings usually don’t point to mistakes.
nw="$nw -Wsign-conversion" # Likewise.
nw="$nw -Wimplicit-fallthrough=5" # We want to allow "fallthrough" comments.
+ nw="$nw -Wold-style-cast" # Warning from glib macros like g_new0
+ nw="$nw -Wuseless-cast" # Likewise
gl_MANYWARN_ALL_GCC([warnings])