summaryrefslogtreecommitdiff
path: root/tests/enchant_providers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/enchant_providers/Makefile.am')
-rw-r--r--tests/enchant_providers/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/enchant_providers/Makefile.am b/tests/enchant_providers/Makefile.am
index 571946f..2ee03f5 100644
--- a/tests/enchant_providers/Makefile.am
+++ b/tests/enchant_providers/Makefile.am
@@ -1,5 +1,12 @@
# FIXME: common up with tests/Makefile.am
+# Get libdir suffix
+if GNU_MAKE
+libdir_subdir=$(shell echo "$(libdir)" | sed -e 's|^$(exec_prefix)/||' | sed -e 's|^/||')
+else
+Tests require GNU Make!
+endif
+
AM_CPPFLAGS = -I$(top_srcdir)/src $(ENCHANT_CFLAGS)
ENCHANT_CONFIG_DIR = config