summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJaehyun Cho <jae_hyun.cho@samsung.com>2018-06-29 14:43:03 +0900
committerJaehyun Cho <jae_hyun.cho@samsung.com>2018-06-29 14:43:03 +0900
commit9386e2dd77f7a1046e8aab56b5e8183c56f8c863 (patch)
tree641bacf9c420ea69fb591491a3c5967566096072 /configure.ac
parent5599f2f70ce18ce2fc042a6e95cf183f06d99d60 (diff)
downloadefl-9386e2dd77f7a1046e8aab56b5e8183c56f8c863.tar.gz
configure: check if realpath program exists
Summary: If realpath program does not exist, then readlink program can be used. Test Plan: Execute configure and check the log "checking for realpath". If realpath program does not exist, then "checking for readlink" log is also printed. Reviewers: woohyun, lauromoura, devilhorns Reviewed By: lauromoura Subscribers: cedric, #committers, zmike Tags: #efl Differential Revision: https://phab.enlightenment.org/D6470
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 48782e88bf..fa8a570447 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1453,7 +1453,15 @@ AC_SUBST([CUSTOM_EXPORTS_MONO_DL_MONO])
# Eos file/library mapping
# Unescaped sed pattern: sed -n 's/src\/lib\/\([a-z0-9_]*\)\/[a-z\/]*\/\([a-z0-9\._]*\)/\2,\1/pg'
-_configure_path=`realpath $0`
+AC_CHECK_PROG([have_realpath], [realpath], [yes], [no])
+if test "x${have_realpath}" = "xyes" ; then
+ _configure_path=`realpath $0`
+else
+ AC_CHECK_PROG([have_readlink], [readlink], [yes], [no])
+ if test "x${have_readlink}" = "xyes" ; then
+ _configure_path=`readlink -f $0`
+ fi
+fi
efl_mono_top_srcdir=`dirname ${_configure_path}`
EFL_MONO_LIBRARY_MAP=`find ${efl_mono_top_srcdir}/src/lib/ -iname "*\.eo" | sed -n 's/.*\/src\/lib\/\(@<:@a-z0-9_@:>@*\)@<:@\/a-z@:>@*\/\(@<:@a-z0-9\._@:>@*\)/\2,\1/pg'`