summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2019-10-05 18:35:00 +0100
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2019-10-05 18:39:38 +0100
commit0f3bbb51f42edf53b28176c916f8057e4db6acdf (patch)
tree178933c6012b0f8da4a0b5ac6c8f65654aeffabe /meson.build
parent9371cdfef8e49bad56afe9e18fd2ed73a043dce0 (diff)
downloadefl-0f3bbb51f42edf53b28176c916f8057e4db6acdf.tar.gz
build - images loaders and saver modules need to link to evas
if your platform is picky enough it won't want to leave unresolved symbols (which wshould be resovled at runtime from the host lib) so we need to link these modules to evas. the problem is due to the complicated build of some modules being static and some shared, evas is declared with evas_goal and this has to be declared after static modules are declared but since i was declaring static and shared at the same time from a table this breaks. so i have to move all the static and shared module stuff into evas_goal into 2 phases. one phase for the static and one for the shared after evas is delcared so evas as a target exists to link to.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b75bcf3e3f..4de9757946 100644
--- a/meson.build
+++ b/meson.build
@@ -247,6 +247,8 @@ endif
ecore_evas_wayland_engine_include_dir = []
+evas_static_list = []
+
evas_lib = ['evas' ,[], false, true, false, false, true, true, ['eina', 'efl', 'eo'], ['vg_common', 'libunibreak']]
evas_img_modules = ['evas' ,[], true, false, false, false, false, false, ['eina', 'efl', 'eo'], ['vg_common', 'libunibreak']]
evas_engines = [join_paths('evas', 'engines'),[], true, false, false, false, false, false, [], []]