summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorVincent Torri <vincent.torri@gmail.com>2019-03-21 11:26:15 +0100
committerDaniel Kolesa <d.kolesa@samsung.com>2019-03-21 11:26:15 +0100
commit1066e5be60eb135700f3ec41c6b184ecbe142f6e (patch)
tree2ce3c3dbb945ed3de910f6ee400b1c0334dd21fc /meson.build
parentb747af5181bc4388240d9e5ccdc4d4505a632cdc (diff)
downloadefl-1066e5be60eb135700f3ec41c6b184ecbe142f6e.tar.gz
Windows, meson build : use posix *printf family function
Summary: the Windows libc has different format flags for the *printf functions, fix this by using the posix version provided with mingw Test Plan: compilation Reviewers: zmike, raster, q66 Reviewed By: q66 Subscribers: cedric, #reviewers, #committers Tags: #efl Differential Revision: https://phab.enlightenment.org/D8432
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ed7c9ea81f..46eecba748 100644
--- a/meson.build
+++ b/meson.build
@@ -120,6 +120,7 @@ foreach lang : ['c', 'objc', 'cpp']
else
error('Version of targetted Windows incorrect')
endif
+ add_global_arguments('-D__USE_MINGW_ANSI_STDIO', language: lang)
endif
endforeach