summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarcel Hollerbach <mail@marcel-hollerbach.de>2019-10-29 12:54:55 -0400
committerMike Blumenkrantz <zmike@samsung.com>2019-10-29 12:54:56 -0400
commit28f630ba418719c36ea679541acc97c59cf5183c (patch)
tree72655186e86d5715a7679682df5a967ff8145246 /meson.build
parent795c37b2a49e089984ec5c266e732ed217449c93 (diff)
downloadefl-28f630ba418719c36ea679541acc97c59cf5183c.tar.gz
meson: redo evas building
Summary: before recent times we had to support static and shared building based on the options of the user, which forced us to complicate our build with the evas_goal hack. the evas_goal hack more or less was the idea of "faking" the evas build in the evas directory, finish all the .eo generation there, then build the modules and make all the static files ready. Then build everything in evas_goal. Now, that we just build everything the same always, we can simply build it in the evas way (removing the evas_goal hack FINALLY), as the same modules are build statically and shared. This also gives us the possibility to build the shared image loaders *again* the the modules directory, which unbreaks peoples build scripts who packaged loader files seperatly. Reviewers: zmike, raster, cedric, stefan_schmidt Reviewed By: zmike Subscribers: #reviewers, #committers Tags: #efl Differential Revision: https://phab.enlightenment.org/D10548
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 2 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 4de9757946..702e38390b 100644
--- a/meson.build
+++ b/meson.build
@@ -249,13 +249,6 @@ ecore_evas_wayland_engine_include_dir = []
evas_static_list = []
-evas_lib = ['evas' ,[], false, true, false, false, true, true, ['eina', 'efl', 'eo'], ['vg_common', 'libunibreak']]
-evas_img_modules = ['evas' ,[], true, false, false, false, false, false, ['eina', 'efl', 'eo'], ['vg_common', 'libunibreak']]
-evas_engines = [join_paths('evas', 'engines'),[], true, false, false, false, false, false, [], []]
-evas_goal = ['evas_goal' ,[], false, true, false, false, false, false, ['eina', 'efl', 'eo'], []]
-
-evas_settings = [ evas_lib, evas_img_modules, evas_goal, evas_engines ]
-
subprojects = [
# name | option | mod | lib | bin | bench | tests | examples | pkg-config options | name of static libs
['evil' ,[] , false, true, false, false, false, false, [], []],
@@ -284,7 +277,8 @@ subprojects = [
['ector' ,[] , false, true, false, false, true, false, ['eina', 'efl'], ['draw', 'triangulator', 'freetype']],
['elput' ,['drm'] , false, true, false, false, true, false, ['eina', 'eldbus'], []],
['ecore_drm2' ,['drm'] , false, true, false, false, false, false, ['ecore'], ['libdrm']],
-['ecore_cocoa' ,['cocoa'] , false, true, false, false, false, false, ['eina'], []]] + evas_settings +[
+['ecore_cocoa' ,['cocoa'] , false, true, false, false, false, false, ['eina'], []],
+['evas' ,[] , true, true, false, false, true, true, ['eina', 'efl', 'eo'], ['vg_common', 'libunibreak']],
['ecore_input_evas' ,[] , false, true, false, false, false, false, ['eina', 'evas'], []],
['ecore_evas' ,[] , true, true, true, false, false, false, ['evas', 'ector'], []],
['ecore_imf' ,[] , true, true, false, false, false, false, ['eina'], []],