summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJongmin Lee <jm105.lee@samsung.com>2019-06-27 08:26:55 +0000
committerMarcel Hollerbach <mail@marcel-hollerbach.de>2019-06-27 15:51:25 +0200
commit3edf75c319c47df598efd55aa6771d8d58c52bb4 (patch)
treed1ed8471bb543d4b2150963b9eeae6d8070d3eaf /meson.build
parentf8aa44eef72c6e9fdf9e1a4848614243cbe09f53 (diff)
downloadefl-3edf75c319c47df598efd55aa6771d8d58c52bb4.tar.gz
meson: add some config definitions
Some config definitions used in source code could not be defined during build config process. - HAVE_XATTR - HAVE_CIPHER - HAVE_SIGNATURE - BUILD_ECORE_EVAS_EWS Reviewed-by: Marcel Hollerbach <mail@marcel-hollerbach.de> Reviewed-by: Vincent Torri <vincent.torri@gmail.com> Differential Revision: https://phab.enlightenment.org/D9192
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 96b33180ed..a6febe01d0 100644
--- a/meson.build
+++ b/meson.build
@@ -225,6 +225,11 @@ elif (get_option('crypto') == 'openssl')
config_h.set('HAVE_OPENSSL', '1')
endif
+if get_option('crypto') != ''
+ config_h.set('HAVE_CIPHER', '1')
+ config_h.set('HAVE_SIGNATURE', '1')
+endif
+
config_h.set_quoted('SHARED_LIB_SUFFIX', '.'+sys_lib_extension)
config_h.set_quoted('MOD_SUFFIX', '.'+sys_mod_extension)
config_h.set_quoted('EXE_SUFFIX', '.'+sys_exe_extension)