summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarcel Hollerbach <mail@marcel-hollerbach.de>2019-03-14 14:26:20 -0400
committerMike Blumenkrantz <zmike@samsung.com>2019-03-14 14:26:21 -0400
commit68a0bfda51727fef8baaacc7356249aacaa0c7de (patch)
tree48bbe430c818e31e55c6c243477898f9d101557c /meson.build
parentaa7ec616647b029c5a9a160426fe0b06bd8d9f84 (diff)
downloadefl-68a0bfda51727fef8baaacc7356249aacaa0c7de.tar.gz
meson: be a bit more helpfull when it comes to bindings
Summary: for now meson would have just used the order that you pass in via -Dbindings=mono,cxx. However this leads to bugs, as cxx for example must be declared before mono can be declared. This fixes this error by forcing a order. Reviewers: zmike, segfaultxavi Reviewed By: zmike Subscribers: cedric, #reviewers, #committers Tags: #efl Differential Revision: https://phab.enlightenment.org/D8341
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 93cd3be56b..061cd623c1 100644
--- a/meson.build
+++ b/meson.build
@@ -422,9 +422,12 @@ if get_option('eolian-bootstrap') == false
subdir(join_paths('src', 'generic', 'emotion'))
bindings = get_option('bindings')
+ bindings_order = ['luajit', 'cxx', 'mono']
- foreach binding : bindings
- subdir(join_paths('src', 'bindings', binding))
+ foreach binding : bindings_order
+ if bindings.contains(binding)
+ subdir(join_paths('src', 'bindings', binding))
+ endif
endforeach
subdir(join_paths('src', 'edje_external'))