summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarcel Hollerbach <mail@marcel-hollerbach.de>2020-05-27 14:38:32 +0200
committerStefan Schmidt <s.schmidt@samsung.com>2020-05-27 15:35:54 +0200
commit7da3eb84ab7147b023f7b2dfab62fa8f18fe073c (patch)
treeb1d490a5ca81ba9dd879609dbe0f4438293667d3 /meson.build
parent28cf881861e5627d8ba7ad608a47fd2b601d3455 (diff)
downloadefl-7da3eb84ab7147b023f7b2dfab62fa8f18fe073c.tar.gz
build: efl-one track all subdirs correctly
this was missed before, so the subdirectories have not been correctly added. With this you can now simply build with efl-one with including <Elementary.h> Reviewed-by: Stefan Schmidt <stefan@datenfreihafen.org> Differential Revision: https://phab.enlightenment.org/D11893
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5f6c339907..06213426ce 100644
--- a/meson.build
+++ b/meson.build
@@ -361,6 +361,7 @@ efl_one_parts = []
efl_one_deps = []
efl_one_eo_deps = []
efl_one_include_dirs = []
+efl_one_sub_dirs = []
tmp_empty = declare_dependency()
foreach package : subprojects
@@ -462,7 +463,9 @@ foreach package : subprojects
foreach subdir : package_header_subdirs
tmp_package_subdirs += join_paths(package_version_name, subdir)
endforeach
-
+ if (package[8] and get_option('efl-one'))
+ efl_one_sub_dirs += [package_version_name] + tmp_package_subdirs
+ endif
pkgconfig.generate(tmp_lib,
name : '-'.join(package_name.split('_')),
subdirs : [package_version_name] + tmp_package_subdirs,
@@ -503,6 +506,7 @@ if (get_option('efl-one'))
pkgconfig.generate(
name : 'efl-one',
+ subdirs : efl_one_sub_dirs,
description: 'Configureation for efl in one big fat .so',
libraries : [efl_one] + eina_pc_deps, #eina is a special case here which drags in m dl & threads
)