summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Kolesa <d.kolesa@samsung.com>2020-07-31 18:21:15 +0200
committerDaniel Kolesa <d.kolesa@samsung.com>2020-07-31 19:01:53 +0200
commit86ee71ce4d792c7e73bf8dd07d89add1d00e93bb (patch)
tree12a1fb603eb36a43042910ab0d6aff137a089225 /meson.build
parentdb14b825494057145788becf712a6451749a474a (diff)
downloadefl-86ee71ce4d792c7e73bf8dd07d89add1d00e93bb.tar.gz
elua: do not link to cffi, load the module instead
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 1 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 90116b67d3..c5078100f4 100644
--- a/meson.build
+++ b/meson.build
@@ -285,15 +285,7 @@ if get_option('lua-interpreter') == 'lua'
error('Lua not found')
endif
if have_elua
- luaver_min = cc.compute_int('LUA_VERSION_NUM - 500',
- prefix: '#include <lua.h>', dependencies: lua
- )
- lua_ffi = dependency('cffi-lua-5.@0@'.format(luaver_min), required: false)
- if not lua_ffi.found()
- error('Elua with interpreter is experimental, disable it or install cffi-lua...')
- else
- message('Using experimental Elua with interpreter support...')
- endif
+ message('Using experimental Elua with interpreter support...')
endif
else
lua = dependency(get_option('lua-interpreter'))