summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLauro Moura <lauromoura@expertisesolutions.com.br>2018-12-17 13:26:47 +0000
committerMarcel Hollerbach <mail@marcel-hollerbach.de>2018-12-17 16:38:40 +0100
commit95069a3038d8ba59a4e8d372d26173c777a84f08 (patch)
tree6b71331051b90996877e1ce595f47ff6cc04b42e /meson.build
parent3f17b4f05494596f7a13c61229d2b4c6766d0a3e (diff)
downloadefl-95069a3038d8ba59a4e8d372d26173c777a84f08.tar.gz
meson: Enable dev flags for cpp
Had to add a pragma around CityHash64 to make it work with -f-visibility=hidden Reviewed-by: Marcel Hollerbach <marcel-hollerbach@t-online.de> Differential Revision: https://phab.enlightenment.org/D7466
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f85681c7cc..876d885a2a 100644
--- a/meson.build
+++ b/meson.build
@@ -91,6 +91,7 @@ foreach cf: dev_cflags_try
endif
endforeach
add_global_arguments(dev_cflags, language: 'c')
+add_global_arguments(dev_cflags, language: 'cpp')
foreach lang : ['c', 'objc', 'cpp']