summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorStefan Schmidt <s.schmidt@samsung.com>2020-05-11 17:17:47 +0200
committerStefan Schmidt <s.schmidt@samsung.com>2020-05-12 13:13:40 +0200
commit9e6e805689fe9c55766706ca11d01495fe8b74cf (patch)
tree6dcc7381aa3d0dec22048af470852d11385532ec /meson.build
parent8538130ba27f23108bcf6cbada75781784612d0f (diff)
downloadefl-9e6e805689fe9c55766706ca11d01495fe8b74cf.tar.gz
build: ensure we set ENABLE_LUA_OLD when using a lua interpreter
We missed to actually set the ENABLE_LUA_OLD. Ross run into some problems with Lua 5.2 builds and we hope this fixes the issue for him. Found and fixed by Marcel Hollerbach (only put in the system by me). Fixes T8705
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 353775f020..0c30d5d042 100644
--- a/meson.build
+++ b/meson.build
@@ -267,6 +267,7 @@ luaold_interpreters = [
lua_pc_name = ''
if get_option('lua-interpreter') == 'lua'
+ config_h.set('ENABLE_LUA_OLD', '1')
foreach l : luaold_interpreters
lua = dependency(l[0], version: l[1], required:false)
lua_pc_name = l[0]