summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorStefan Schmidt <s.schmidt@samsung.com>2020-05-28 11:42:59 +0200
committerStefan Schmidt <s.schmidt@samsung.com>2020-05-29 12:54:53 +0200
commitb20a691d1b29f2e49f08bc0e48dce161a674b79a (patch)
treeb6e033beb611880af0a76f7aa95231e681379d87 /meson.build
parent23e8715070bb9d75a02123c2ab5ba200699f63af (diff)
downloadefl-b20a691d1b29f2e49f08bc0e48dce161a674b79a.tar.gz
build: ensure we set all needed asan option for check run as well
Normally we would set the needed detect_odr_violation=0 form our CI scripts. Move it here to ensure we have it set and it does not get forgotten when meson overrides the env far. Fixes the ASAN job on CI. Reviewed-by: Marcel Hollerbach <mail@marcel-hollerbach.de> Differential Revision: https://phab.enlightenment.org/D11902
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 33281b2714..2ede020824 100644
--- a/meson.build
+++ b/meson.build
@@ -14,7 +14,7 @@ test_env = environment()
test_env.set('EFL_RUN_IN_TREE', '1')
if get_option('b_sanitize') == 'address'
- test_env.set('ASAN_OPTIONS', 'detect_leaks=0')
+ test_env.set('ASAN_OPTIONS', 'detect_leaks=0:detect_odr_violation=0')
endif
version_arr = meson.project_version().split('.')