summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorStefan Schmidt <s.schmidt@samsung.com>2019-06-04 21:11:20 +0200
committerMarcel Hollerbach <mail@marcel-hollerbach.de>2019-06-20 17:29:35 +0200
commitb9756eef9b821764e31ecfd32a482ceba6fcfd5b (patch)
tree2ce155a425f77e68926e11e282100f2363726623 /meson.build
parentb0c29edd7853abd893559d84a29b89a7bd201e50 (diff)
downloadefl-b9756eef9b821764e31ecfd32a482ceba6fcfd5b.tar.gz
build: remove no longer needed eolian-bootstrap target
This basically reverts ac606105. It was added to help the windows cross builds on our CI. It served a purpose but with the requirements on native eet, edje_cc and up to elm_prefs_cc we end up with a full native build of EFL in most cases anyway. A full meson build of EFL with examples, bindings and tests disabled is actually quite fast and makes sure we have the latest needed on the CI for the cross build. I switched over to this a week ago, so we can get rid of this extra target to maintain. Differential Revision: https://phab.enlightenment.org/D9086 Signed-off-by: Stefan Schmidt <s.schmidt@samsung.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build44
1 files changed, 16 insertions, 28 deletions
diff --git a/meson.build b/meson.build
index 04ed2a20f8..96b33180ed 100644
--- a/meson.build
+++ b/meson.build
@@ -243,12 +243,6 @@ endif
ecore_evas_wayland_engine_include_dir = []
-boot_strap_eolian = [
- ['evil' ,[] , false, true, false, false, false, false, [], []],
- ['eina' ,[] , false, true, false, false, false, false, [], []],
- ['eolian' ,[] , false, true, true, false, false, false, ['eina'], []],
-]
-
evas_lib = ['evas' ,[], false, true, false, false, true, true, ['eina', 'efl', 'eo'], ['vg_common', 'libunibreak']]
evas_img_modules = ['evas' ,[], true, false, false, false, false, false, ['eina', 'efl', 'eo'], ['vg_common', 'libunibreak']]
evas_engines = [join_paths('evas', 'engines'),[], true, false, false, false, false, false, [], []]
@@ -331,10 +325,6 @@ test_dirs = []
example_dirs = []
tmp_empty = declare_dependency()
-if get_option('eolian-bootstrap')
- subprojects = boot_strap_eolian
-endif
-
foreach package : subprojects
package_name = package[0]
package_version_name = '-'.join(package_name.split('_')) + '-' + version_major
@@ -434,28 +424,26 @@ foreach package : subprojects
endforeach
-subdir('cmakeconfig')
#build this later, as the debug services are depending on ecore
-if get_option('eolian-bootstrap') == false
- subdir(join_paths('src', 'bin', 'efl'))
+subdir(join_paths('src', 'bin', 'efl'))
- subdir(join_paths('src', 'generic', 'evas'))
- if sys_windows == false
- subdir(join_paths('src', 'generic', 'emotion'))
- endif
+subdir(join_paths('src', 'generic', 'evas'))
+if sys_windows == false
+ subdir(join_paths('src', 'generic', 'emotion'))
+endif
+subdir('cmakeconfig')
- bindings = get_option('bindings')
- bindings_order = ['luajit', 'cxx', 'mono']
+bindings = get_option('bindings')
+bindings_order = ['luajit', 'cxx', 'mono']
- foreach binding : bindings_order
- if bindings.contains(binding)
- subdir(join_paths('src', 'bindings', binding))
- endif
- endforeach
+foreach binding : bindings_order
+ if bindings.contains(binding)
+ subdir(join_paths('src', 'bindings', binding))
+ endif
+endforeach
- subdir(join_paths('src', 'edje_external'))
- subdir(join_paths('data'))
-endif
+subdir(join_paths('src', 'edje_external'))
+subdir(join_paths('data'))
if get_option('build-tests')
check = dependency('check')
@@ -484,7 +472,7 @@ endforeach
doxygen = find_program('doxygen', required : false)
-if get_option('eolian-bootstrap') == false and doxygen.found()
+if doxygen.found()
subdir('doc')
endif