summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarcel Hollerbach <mail@marcel-hollerbach.de>2020-09-02 09:25:51 +0200
committerMarcel Hollerbach <mail@marcel-hollerbach.de>2020-09-02 09:25:51 +0200
commite2a1cdfda76dd0061ef8e0ab25aee4e042304366 (patch)
treec79d238fb76828a0282ca521f292e31db44367b2 /meson.build
parentf9ade56cf8de4f040572f368da644f2a83bdee92 (diff)
downloadefl-e2a1cdfda76dd0061ef8e0ab25aee4e042304366.tar.gz
build: only find env once
this was a bit messy, and we might have caused a bug on the ML with that.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c7af80917f..ba34a9c311 100644
--- a/meson.build
+++ b/meson.build
@@ -126,6 +126,8 @@ if sys_sun
add_global_arguments('-D_POSIX_PTHREAD_SEMANTICS', language: 'c')
endif
+env = find_program('env', native: true)
+
config_h = configuration_data()
config_h.set_quoted('MODULE_ARCH', version_name)
config_h.set_quoted('PACKAGE', meson.project_name())