summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2018-12-27 15:24:08 +0000
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2018-12-27 15:24:08 +0000
commitf532be51bc4414975e0fb0a5798eb96151219dea (patch)
treefa868d7549e4b3e115cacb3226af61f8bf557c60 /meson.build
parent91990b7cf8024d13a89edbeddb873869eda21a87 (diff)
downloadefl-f532be51bc4414975e0fb0a5798eb96151219dea.tar.gz
meosn - fix install of scripts and bins and their timestamps and modes
i was comparing the bindir results of aurtofoo vs meson and some things were missing/poking out at me. this makes them be in sync - install the ewl_wl+test obnaries, ensure to chmod +x+r etc. scritps AND install them
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 876d885a2a..b3845ab124 100644
--- a/meson.build
+++ b/meson.build
@@ -4,11 +4,12 @@ project('efl', ['c','cpp'],
meson_version : '>=0.47'
)
+chmod = join_paths(meson.source_root(), 'meson/meson-chmod.sh')
+
if host_machine.system() == 'darwin'
add_languages('objc')
endif
-
clean_check = run_command('meson/clean_check.sh')
if clean_check.returncode() == 0
error('Meson build requires a clean source tree')