summaryrefslogtreecommitdiff
path: root/header_checks/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'header_checks/meson.build')
-rw-r--r--header_checks/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/header_checks/meson.build b/header_checks/meson.build
index 8ead497882..21545607b8 100644
--- a/header_checks/meson.build
+++ b/header_checks/meson.build
@@ -194,6 +194,10 @@ if (cc.has_header('sys/mman.h'))
config_h.set10('HAVE_MMAN_H', true)
endif
+if config_h.has('HAVE_LISTXATTR') and config_h.has('HAVE_SETXATTR') and config_h.has('HAVE_GETXATTR')
+ config_h.set10('HAVE_XATTR', true)
+endif
+
regexp = []
if sys_windows == true
regexp = cc.find_library('regex',