summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@osg.samsung.com>2015-08-10 12:55:09 +0200
committerStefan Schmidt <stefan@osg.samsung.com>2015-08-10 13:00:00 +0200
commit098917f3220352d5c4f7b0fd2d0ad9566d9645af (patch)
tree56fbfc299830eb8cb7af02cacf3a84deac8d1239 /Makefile.am
parent6ec61dea669d8c48bc0a8afcbff5c5abd82cd906 (diff)
downloadelementary-098917f3220352d5c4f7b0fd2d0ad9566d9645af.tar.gz
build: Exclude some more files from coverage as they are not in the correct path
These files come from some modules in src/modules while we set out base dir to src/lib. In result these files are search for in src/lib and not found. In the long term we want to find out how to collect them as well but for now a working coverage is already good. Overall coverage rate: lines......: 18.1% (12596 of 69412 lines) functions..: 18.6% (1766 of 9500 functions) Will work on getting these run by jenkins once it is back.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 72a2d3594..3cb5d0ac2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -138,7 +138,8 @@ lcov-report:
lcov --remove $(top_builddir)/coverage/coverage.cleaned.info '*/elm_test_*' --output-file $(top_builddir)/coverage/coverage.cleaned2.info
lcov --remove $(top_builddir)/coverage/coverage.cleaned2.info '*/elm_suite.c' --output-file $(top_builddir)/coverage/coverage.cleaned3.info
lcov --remove $(top_builddir)/coverage/coverage.cleaned3.info '*NONE*' --output-file $(top_builddir)/coverage/coverage.cleaned4.info
- genhtml --branch-coverage -t "$(PACKAGE_STRING)" -o $(top_builddir)/coverage/html $(top_builddir)/coverage/coverage.cleaned4.info
+ lcov --remove $(top_builddir)/coverage/coverage.cleaned4.info '*/datetime_input_ctxpopup.c' '*/elm_horizontal_box.c' '*/elm_vertical_frame.c' '*/elm_vertical_box.c' '*/elm_horizontal_frame.c' '*/prefs_iface.c' '*/elm_swallow.c' --output-file $(top_builddir)/coverage/coverage.cleaned5.info
+ genhtml --branch-coverage -t "$(PACKAGE_STRING)" -o $(top_builddir)/coverage/html $(top_builddir)/coverage/coverage.cleaned5.info
@echo "Coverage Report at $(top_builddir)/coverage/html"
endif