summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2014-09-21 11:11:28 +0900
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2014-09-21 11:11:28 +0900
commit43c7552411379c17e5548dd1d22375a7847bfa2c (patch)
tree2e4aae3101b5e596b473b73a165156749a4884e4 /Makefile.am
parentb1970bec0059bc2ff7fcc9d14f15c4c1a059a106 (diff)
downloadelementary-43c7552411379c17e5548dd1d22375a7847bfa2c.tar.gz
elm - we should not get our pc files to use hidden libs like x/wl
ecore_x, ecore_wl, ecore_drm etc. were being linked to clients as they were added to the pc file - they should not have been. elm hides these. it's meant to hide them. remove them from the pc file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e85ba36c1..70f7a92fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -86,6 +86,7 @@ $(SED) \
-e 's,@pkgdatadir\@,$(pkgdatadir),g' \
-e 's,@requirement_elm_pc\@,$(requirement_elm_pc),g' \
-e 's,@ELEMENTARY_LIBS\@,$(ELEMENTARY_LIBS),g' \
+-e 's,@ELEMENTARY_PC_LIBS\@,$(ELEMENTARY_PC_LIBS),g' \
< $< > $@ || rm $@
pc_verbose = $(pc_verbose_@AM_V@)