summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Schmidt <s.schmidt@samsung.com>2015-04-08 17:40:02 +0200
committerStefan Schmidt <s.schmidt@samsung.com>2015-04-08 17:41:58 +0200
commit0f427650ac0879cf385bd92643127499318bcc45 (patch)
tree8bd872edfc32bf88854df261dfe48b5833be897a /configure.ac
parentcce799dedad121448a70d1cd1a9824470f75efe3 (diff)
downloadelementary-0f427650ac0879cf385bd92643127499318bcc45.tar.gz
build: Allow to define path for eldbus-codegen binary
Since the latest elm colorclass changes we need eldbus-codegen to generate some files. Not all setups have this in their normal $PATH so let allow these setups to set the correct path during configure. This allows our Jenkins setup as well as others to work again.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5695a1d05..f3a3a3740 100644
--- a/configure.ac
+++ b/configure.ac
@@ -192,6 +192,7 @@ EFL_WITH_BIN([elementary], [elementary-codegen], [elementary_codegen])
EFL_WITH_BIN([elementary], [elm-prefs-cc], [elm_prefs_cc])
EFL_WITH_BIN([eolian], [eolian-gen], [eolian_gen])
EFL_WITH_BIN([eolian-cxx], [eolian-cxx], [eolian_cxx])
+EFL_WITH_BIN([eldbus], [eldbus_codegen], [eldbus-codegen])
# Force the helper to try external eolian generators
AM_CONDITIONAL([HAVE_EOLIAN_GEN], [true])
AM_CONDITIONAL([HAVE_EOLIAN_CXX], [true])
@@ -560,6 +561,7 @@ echo " elementary_codegen.......: ${elementary_codegen}"
echo " elm_prefs_cc.............: ${elm_prefs_cc}"
echo " eolian_gen...............: ${eolian_gen}"
echo " eolian_cxx...............: ${eolian_cxx}"
+echo " eldbus_codegen...........: ${eldbus_codegen}"
echo
echo " Build elementary_test....: ${have_elementary_test}"
echo " Build elementary_codegen.: ${have_elementary_codegen}"