summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSavio Sena <savio.sena@acm.org>2014-07-22 06:56:04 -0300
committerSavio Sena <savio.sena@acm.org>2014-07-22 06:56:04 -0300
commit69e67deb34e9070ff29546f743b07ceaf313b81b (patch)
treec268727b193e497bae2de3dc1399b08c1d0da6b8 /configure.ac
parent72ac26c1dacbc4ea32edd45406e3605951ef61ad (diff)
downloadelementary-69e67deb34e9070ff29546f743b07ceaf313b81b.tar.gz
autotools: Fixed C++ build globally.
Previously I removed -fPIC from example LDFLAGS and CXXFLAGS. Now I'm adding "-fPIC -DPIC" to configure.ac conditioned to HAVE_CXX11. This commit fixes 'make check'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 697bbd7af..8900eb140 100644
--- a/configure.ac
+++ b/configure.ac
@@ -251,6 +251,8 @@ if test "x${HAVE_CXX11}" = "x1" -a "x${want_cxx11}" = "xyes"; then
)
fi
AM_CONDITIONAL([HAVE_CXX11], [test "x${have_cxx11}" = "xyes"])
+AM_CONDITIONAL([HAVE_CXX11], [LDFLAGS="${LDFLAGS} -shared -fPIC -DPIC"])
+AM_CONDITIONAL([HAVE_CXX11], [CXXFLAGS="${CXXFLAGS} -fPIC -DPIC"])
have_elementary_x="no"
want_elementary_x="auto"