summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuciana Magno de Almeida <luciana@expertisesolutions.com.br>2014-12-16 19:04:43 -0200
committerFelipe Magno de Almeida <felipe@expertisesolutions.com.br>2015-08-25 03:42:34 -0300
commitcf4d84c85b48d32fd85deeafdc7aee4543875725 (patch)
tree0c5c7a61507819bff113eb8ee8883c7026f33465 /configure.ac
parentdfb979950cfcebc21d1b0e933d4f02ab2084e304 (diff)
downloadelementary-cf4d84c85b48d32fd85deeafdc7aee4543875725.tar.gz
cxx: Added examples and tutorial for C++ binding
Summary: Added the following examples: * bg_cxx_example_01 * bg_cxx_example_02 * bubble_cxx_example_01 * button_cxx_example_00 * button_cxx_example_01 * calendar_cxx_example_01 * calendar_cxx_example_02 * calendar_cxx_example_03 * calendar_cxx_example_04 * calendar_cxx_example_05 * clock_cxx_example * datetime_cxx_example * glview_cxx_example_01 * hoversel_cxx_example_01 * icon_cxx_example_01 * location_cxx_example_01 * menu_cxx_example_01 * popup_cxx_example_01 * radio_cxx_example_01 * separator_cxx_example_01 * slider_cxx_example * spinner_cxx_example * table_cxx_example_01 * table_cxx_example_02 * thumb_cxx_example_01 Added documentation for the above examples, as well as how using lambdas with C++ elm binding. How to use autohide feature and how to use the C++ wrappers to create windows, widgets and call Eo functions from them with automatic C++ type conversion and how to use signals from C++.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c016849c7..3287329ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,10 +31,10 @@ EFL_INIT
# C++ bindings
AC_ARG_ENABLE([cxx-bindings],
- [AS_HELP_STRING([--enable-cxx-bindings],
- [enable C++11 bindings. @<:@default=disabled@:>@])],
+ [AS_HELP_STRING([--disable-cxx-bindings],
+ [Disable C++11 bindings. @<:@default=enabled@:>@])],
[want_cxx11="${enableval}"],
- [want_cxx11="no"])
+ [want_cxx11="yes"])
# Tests
@@ -271,6 +271,7 @@ if test "x${HAVE_CXX11}" = "x1" -a "x${want_cxx11}" = "xyes"; then
eina-cxx >= efl_version
evas-cxx >= efl_version
eio-cxx >= efl_version
+ edje-cxx >= efl_version
],
[
requirement_elm_pc="${requirement_elm_pc} \
@@ -279,10 +280,12 @@ if test "x${HAVE_CXX11}" = "x1" -a "x${want_cxx11}" = "xyes"; then
eina-cxx >= efl_version \
evas-cxx >= efl_version \
eio-cxx >= efl_version \
+ edje-cxx >= efl_version \
"
have_cxx11="yes"
LDFLAGS="${LDFLAGS} -fPIC -DPIC"
CXXFLAGS="${CXXFLAGS} -fPIC -DPIC"
+ AC_CONFIG_FILES([src/lib/Elementary.hh])
],
[have_cxx11="no"]
)