summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorq66 <quaker66@gmail.com>2014-08-07 22:49:09 +0100
committerq66 <quaker66@gmail.com>2014-08-07 22:49:09 +0100
commitdea408a2a4f1651f8ade3c4105b9d26b8cfe29b0 (patch)
tree80666b23bacedf768c2d8021e51b58aad461e086 /configure.ac
parent40034a82ee5be6d4ec362d6642b2fedcf9a9cca2 (diff)
downloadelementary-dea408a2a4f1651f8ade3c4105b9d26b8cfe29b0.tar.gz
autotools: install .pc files to the correct directory on FreeBSD
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 293482434..21b7e2c14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,12 @@ ELM_UNIX_DEF="#undef"
ELM_WIN32_DEF="#undef"
have_windows="no"
have_dlopen="no"
+have_freebsd="no"
+case "$host_os" in
+ freebsd*)
+ have_freebsd="yes"
+ ;;
+esac
case "$host_os" in
mingw*)
PKG_CHECK_MODULES([EVIL], [evil])
@@ -88,6 +94,7 @@ esac
AM_CONDITIONAL([BUILD_RUN], [test "x$have_socket" = "xyes"])
AM_CONDITIONAL([BUILD_MODULES], [test "x$have_dlopen" = "xyes"])
+AM_CONDITIONAL([HAVE_FREEBSD], [test "x${have_freebsd}" = "xyes"])
AC_SUBST([default_engine])
AC_DEFINE_UNQUOTED([DEFAULT_ENGINE], ["$default_engine"], ["Default engine according to host"])