summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Kolesa <d.kolesa@osg.samsung.com>2015-08-05 12:27:34 +0100
committerDaniel Kolesa <d.kolesa@osg.samsung.com>2015-08-05 12:27:34 +0100
commiteb5b24aae9aacc33466a014096feb6dd8871dd4d (patch)
tree7e4f5205c49ab305fc6e83680127668324fe5831 /configure.ac
parentdec379aca1438d4c66865eb3a694903189b58477 (diff)
downloadelementary-eb5b24aae9aacc33466a014096feb6dd8871dd4d.tar.gz
configure: we can actually safely imply -ldl is only needed on linux
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 4 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 2abe41834..c016849c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -337,16 +337,7 @@ dnl managed by evil
have_dlopen="yes"
requirement_elm_libs="-ldl ${requirement_elm_libs}"
;;
- *solaris*)
- have_dlopen="yes"
- ;;
- darwin*)
- have_dlopen="yes"
- ;;
- freebsd*|openbsd*|netbsd*|dragonfly*)
- have_dlopen="yes"
- ;;
- *)
+ linux*)
AC_CHECK_LIB([dl], [dlopen], [res=yes], [res=no])
if test "x$res" = "xyes"; then
AC_CHECK_LIB([dl], [dladdr], AC_DEFINE([HAVE_DLADDR], [1], [Define to 1 if you have the `dladdr' function.]))
@@ -354,6 +345,9 @@ dnl managed by evil
have_dlopen="yes"
fi
;;
+ *)
+ have_dlopen="yes"
+ ;;
esac
AM_CONDITIONAL([BUILD_MODULES], [test "x$have_dlopen" = "xyes"])